summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2012-06-26 11:05:00 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2012-07-07 20:25:55 +0000
commit22e97ea43b49a104422bcb2750b4d5197e6cd7c0 (patch)
treee5bcd90690c7b32ecc611a2174ca003e122d5b1b
parentda4a5d60832302866dbe109a74ef977a1d66a04a (diff)
downloadaports-22e97ea43b49a104422bcb2750b4d5197e6cd7c0.tar.bz2
aports-22e97ea43b49a104422bcb2750b4d5197e6cd7c0.tar.xz
testing/libcli: new aport
bcli provides support for using the arrow keys for command-line editing. Up and Down arrows will cycle through the command history, and Left & Right can be used for editing the current command line. libcli also works out the shortest way of entering a command, so if you have a command "show users grep foobar" defined, you can enter "sh us g foobar" if that is the shortest possible way of doing it. https://github.com/dparrish/libcli
-rw-r--r--testing/libcli/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/libcli/APKBUILD b/testing/libcli/APKBUILD
new file mode 100644
index 000000000..66bbd0572
--- /dev/null
+++ b/testing/libcli/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer:
+pkgname=libcli
+pkgver=1.9.6
+pkgrel=0
+pkgdesc="A library for including a Cisco-like command-line interface"
+url="https://github.com/dparrish/libcli"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="https://github.com/downloads/dparrish/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="e52866b2cf1592d1557d2193db592f94 libcli-1.9.6.tar.gz"