summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2012-04-19 06:02:15 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2012-04-19 06:02:15 +0000
commit4d045cc3de0e18b557fff1f5f35d886285a7a728 (patch)
tree63248964be1c85677d2ee256d74247801817c561
parent71ffa9310ea57976f3da266e76324df5201f0ceb (diff)
parent6cbd042027a14065e171e3a0e26c03a3a8aee720 (diff)
downloadaports-4d045cc3de0e18b557fff1f5f35d886285a7a728.tar.bz2
aports-4d045cc3de0e18b557fff1f5f35d886285a7a728.tar.xz
Merge git://dev.alpinelinux.org/aports
-rw-r--r--main/dbus/APKBUILD6
-rw-r--r--main/htop/APKBUILD11
-rw-r--r--main/libnotify/APKBUILD6
-rw-r--r--main/mutt/APKBUILD31
-rw-r--r--testing/py-rtslib/APKBUILD6
-rw-r--r--testing/targetcli/APKBUILD11
-rwxr-xr-xtesting/targetcli/targetcli.initd27
7 files changed, 76 insertions, 22 deletions
diff --git a/main/dbus/APKBUILD b/main/dbus/APKBUILD
index bb5f8ec3c..7e31bf4ff 100644
--- a/main/dbus/APKBUILD
+++ b/main/dbus/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dbus
-pkgver=1.4.16
-pkgrel=3
+pkgver=1.4.20
+pkgrel=0
pkgdesc="Freedesktop.org message bus system"
url="http://www.freedesktop.org/Software/dbus"
pkggroups="messagebus"
@@ -56,5 +56,5 @@ x11() {
mv "$pkgdir"/usr/bin/dbus-launch "$subpkgdir"/usr/bin/
}
-md5sums="44a2a10678e7e50460879c3eb4453a65 dbus-1.4.16.tar.gz
+md5sums="79eca2f2c1894ac347acce128314428b dbus-1.4.20.tar.gz
bc835765907698a95da8d8e5bf199378 dbus.initd"
diff --git a/main/htop/APKBUILD b/main/htop/APKBUILD
index d1107903d..ed4e00ec0 100644
--- a/main/htop/APKBUILD
+++ b/main/htop/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer:Carlo Landmeter
pkgname=htop
-pkgver=0.9
+pkgver=1.0.1
pkgrel=0
pkgdesc="An interactive process viewer for Linux"
url="http://htop.sourceforge.net"
@@ -12,11 +12,16 @@ source="http://surfnet.dl.sourceforge.net/sourceforge/htop/$pkgname-$pkgver.tar.
subpackages="$pkgname-doc"
+_builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd $startdir/src/$pkgname-$pkgver
+ cd "$_builddir"
./configure --prefix=/usr --mandir=/usr/share/man
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
}
-md5sums="7c5507f35f363f3f40183a2ba3c561f8 htop-0.9.tar.gz"
+md5sums="d3b80d905a6bff03f13896870787f901 htop-1.0.1.tar.gz"
diff --git a/main/libnotify/APKBUILD b/main/libnotify/APKBUILD
index 1cbc01716..679c50093 100644
--- a/main/libnotify/APKBUILD
+++ b/main/libnotify/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libnotify
-pkgver=0.7.4
+pkgver=0.7.5
pkgrel=0
pkgdesc="Desktop notification library"
url="http://library.gnome.org/devel/notification-spec/"
@@ -10,7 +10,7 @@ subpackages="$pkgname-dev $pkgname-doc"
depends=
depends_dev="gdk-pixbuf-dev glib-dev dbus-dev"
makedepends="$depends_dev gtk+3.0-dev"
-source="http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+source="http://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -25,4 +25,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" -name '*.la' -delete
}
-md5sums="5475de4675b87d56c5e8b04a8ac6cc56 libnotify-0.7.4.tar.bz2"
+md5sums="8e9f8bd26517bc197ab1df748df289a9 libnotify-0.7.5.tar.xz"
diff --git a/main/mutt/APKBUILD b/main/mutt/APKBUILD
index 69ab253a4..0104c9f68 100644
--- a/main/mutt/APKBUILD
+++ b/main/mutt/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Andrew Manison<amanison@anselsystems.com>
# Maintainer: Andrew Manison<amanison@anselsystems.com>
pkgname=mutt
-pkgver=1.4.2.3
-pkgrel=5
+pkgver=1.5.21
+pkgrel=0
pkgdesc="a small but very powerful text-mode email client"
url="http://www.mutt.org"
arch="all"
license="GPL"
depends=
-makedepends="openssl-dev ncurses-dev libiconv-dev gettext-dev"
+makedepends="cyrus-sasl-dev db-dev gettext-dev gpgme-dev libiconv-dev
+ libidn-dev ncurses-dev openssl-dev perl"
install=
subpackages="$pkgname-doc $pkgname-lang"
-source="ftp://ftp.mutt.org/$pkgname/$pkgname-$pkgver.tar.gz"
+source="ftp://ftp.mutt.org/pub/mutt/devel/mutt-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -22,6 +23,7 @@ prepare() {
build() {
cd "$_builddir"
+ ISPELL=/usr/bin/hunspell \
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -29,17 +31,34 @@ build() {
--enable-imap \
--enable-pop \
--enable-smtp \
+ --enable-hcache \
+ --enable-gpgme \
--with-curses \
--with-mailpath=/var/spool/mail \
--with-docdir=/usr/share/doc/mutt \
--without-included-gettext \
- --with-ssl
+ --with-ssl \
+ --with-sasl \
+ || return 1
make || return 1
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir"/etc/*.dist \
+ "$pkgdir"/etc/mime.types \
+ "$pkgdir"/usr/bin/muttbug \
+ "$pkgdir"/usr/bin/flea \
+ || return 1
+
+ # fix up default config
+ cat contrib/gpg.rc >> "$pkgdir"/etc/Muttrc
+ grep -C 5 "^color" contrib/sample.muttrc >> "$pkgdir"/etc/Muttrc
+ echo "source /etc/Muttrc.local" >> "$pkgdir"/etc/Muttrc
+ echo "# Local configuration for Mutt." > "$pkgdir"/etc/Muttrc.local
+
}
-md5sums="dcb94661827dd090fa813e73e122ea0c mutt-1.4.2.3.tar.gz"
+md5sums="a29db8f1d51e2f10c070bf88e8a553fd mutt-1.5.21.tar.gz"
diff --git a/testing/py-rtslib/APKBUILD b/testing/py-rtslib/APKBUILD
index 97ab4238f..34f135caa 100644
--- a/testing/py-rtslib/APKBUILD
+++ b/testing/py-rtslib/APKBUILD
@@ -2,10 +2,10 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-rtslib
_realname=rtslib
-pkgver=2.1_p9
+pkgver=2.1_p13
_ver=${pkgver/_rc/rc}
_ver=${_ver/_p/.fb}
-pkgrel=1
+pkgrel=0
pkgdesc="Python library that provides an object API to RisingTide Systems generic SCSI Target"
url="https://github.com/agrover/rtslib-fb"
arch="noarch"
@@ -58,4 +58,4 @@ package() {
python setup.py install --root="$pkgdir"
}
-md5sums="3c7632404c4a39d8517f0144ffbd32c6 rtslib-2.1.fb9.tar.gz"
+md5sums="77f5e3a60f7a2f94d9f2c372673f8d08 rtslib-2.1.fb13.tar.gz"
diff --git a/testing/targetcli/APKBUILD b/testing/targetcli/APKBUILD
index 5d5285a84..f0639458f 100644
--- a/testing/targetcli/APKBUILD
+++ b/testing/targetcli/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=targetcli
-pkgver=2.0_rc1_p7
+pkgver=2.0_rc1_p11
_ver=${pkgver/_rc/rc}
_ver=${_ver/_p/.fb}
pkgrel=1
@@ -32,7 +32,7 @@ snapshot() {
cd targetcli-fb.git
git fetch || return 1
fi
-
+ echo $_gittag $SRCDEST $pkgname $_ver
git archive --prefix=$pkgname/ -o "$SRCDEST"/$pkgname-$_ver.tar.gz $_gittag
scp "$SRCDEST"/$pkgname-$_ver.tar.gz dev.alpinelinux.org:/archive/$pkgname/
}
@@ -57,7 +57,10 @@ build() {
package() {
cd "$_builddir"
python setup.py install --root="$pkgdir"
- install -D -m644 targetcli.8.gz "$pkgdir"/usr/share/man/man8/targetcli.8.gz
+ mkdir -p "$pkgdir"/var/lib/target/fabric
+ mkdir -p "$pkgdir"/etc/target
+ install -D -m644 $pkgname.8.gz "$pkgdir"/usr/share/man/man8/$pkgname.8.gz
+ install -D -m755 ../../$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
}
-md5sums="70952d94edd866d071ab208d95acde48 targetcli-2.0rc1.fb7.tar.gz"
+md5sums="16f493b0e9f2aa944e6a1de150b7d9ab targetcli-2.0rc1.fb11.tar.gz"
diff --git a/testing/targetcli/targetcli.initd b/testing/targetcli/targetcli.initd
new file mode 100755
index 000000000..3dbbb9ec5
--- /dev/null
+++ b/testing/targetcli/targetcli.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+
+description="Administration tool for managing RisingTide Systems storage targets"
+command="/usr/bin/targetcli"
+modules="target_core_mod iscsi_target_mod"
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting ${RC_SVCNAME}"
+ mount -t configfs none /sys/kernel/config
+ for mod in modules; do
+ modprobe $mod
+ done
+ $command restoreconfig clear_existing=true
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${RC_SVCNAME}"
+ $command clearconfig confirm=true
+ umount /sys/kernel/config
+ eend $?
+}