summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-03-15 21:12:00 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-03-15 21:12:00 +0000
commit66ef745e031af5613e81dda39de1ffae141492a2 (patch)
tree581ed7dbec51d0597d793bb1677b5e4e623f5b60
parent00cac1741b7e99ed5b9d449a6b85b5a48f9c6eaf (diff)
parent536baf944938c8c003a9331d527add08dab436ad (diff)
downloadaports-66ef745e031af5613e81dda39de1ffae141492a2.tar.bz2
aports-66ef745e031af5613e81dda39de1ffae141492a2.tar.xz
Merge git://git.alpinelinux.org/aports
-rw-r--r--main/monkeysphere/APKBUILD (renamed from testing/monkeysphere/APKBUILD)0
-rw-r--r--testing/freeciv/APKBUILD44
-rw-r--r--testing/lua-posixtz/APKBUILD37
-rw-r--r--testing/nodejs/APKBUILD48
-rw-r--r--testing/nodejs/nodejs-multiplicity.patch10
-rw-r--r--testing/nodejs/nodejs-uclibc.patch20
-rw-r--r--testing/tzdata/APKBUILD11
7 files changed, 169 insertions, 1 deletions
diff --git a/testing/monkeysphere/APKBUILD b/main/monkeysphere/APKBUILD
index bf1196617..bf1196617 100644
--- a/testing/monkeysphere/APKBUILD
+++ b/main/monkeysphere/APKBUILD
diff --git a/testing/freeciv/APKBUILD b/testing/freeciv/APKBUILD
new file mode 100644
index 000000000..91ac2fa59
--- /dev/null
+++ b/testing/freeciv/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=freeciv
+pkgver=2.2.5
+pkgrel=0
+pkgdesc="civilization 2 clone"
+url="http://freeciv.wikia.org/"
+arch="all"
+license="GPL"
+depends="$pkgname-server"
+makedepends="gtk+-dev gzip"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-server"
+source="http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+server() {
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/freeciv-server "$subpkgdir"/usr/bin/freeciv-server
+}
+
+md5sums="e717de02c77139593f21b930245d1709 freeciv-2.2.5.tar.bz2"
diff --git a/testing/lua-posixtz/APKBUILD b/testing/lua-posixtz/APKBUILD
new file mode 100644
index 000000000..96278f13d
--- /dev/null
+++ b/testing/lua-posixtz/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=lua-posixtz
+pkgver=0.1
+pkgrel=0
+pkgdesc="Lua module to extract POSIX timezone from tzdata"
+url="http://git.alpinelinux.org/cgit/ncopa/posixtz.git/"
+arch="all"
+license="GPLv2"
+depends=
+makedepends=
+install=
+subpackages=
+source="http://git.alpinelinux.org/cgit/ncopa/posixtz.git/snapshot/posixtz-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/posixtz-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make posixtz.so || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D posixtz.so "$pkgdir"/usr/lib/lua/5.1/posixtz.so
+}
+
+md5sums="be1ca94f79abfa367b4c54a51737ba91 posixtz-0.1.tar.bz2"
diff --git a/testing/nodejs/APKBUILD b/testing/nodejs/APKBUILD
new file mode 100644
index 000000000..fe5acb8e0
--- /dev/null
+++ b/testing/nodejs/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=nodejs
+pkgver=0.4.2
+pkgrel=0
+pkgdesc="event-oriented javascript framework and execution environment"
+url="http://nodejs.org/"
+
+# v8 is not portable so we have to list archs by hand
+arch="x86 x86_64 arm"
+
+license="MIT BSD Apache-2"
+depends=
+depends_dev=
+makedepends="$depends_dev python libev-dev c-ares-dev openssl-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://nodejs.org/dist/node-v${pkgver}.tar.gz
+ nodejs-uclibc.patch
+ nodejs-multiplicity.patch"
+
+_builddir="${srcdir}/node-v${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --shared-cares \
+ --shared-libev
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="9e9e791e125f6a601ebc663dc99c72a8 node-v0.4.2.tar.gz
+b5d7568f58bb9a14d5b9a971e89560c6 nodejs-uclibc.patch
+912d504d56fb194b4ceda8f693f6e200 nodejs-multiplicity.patch"
diff --git a/testing/nodejs/nodejs-multiplicity.patch b/testing/nodejs/nodejs-multiplicity.patch
new file mode 100644
index 000000000..87479690d
--- /dev/null
+++ b/testing/nodejs/nodejs-multiplicity.patch
@@ -0,0 +1,10 @@
+--- node-v0.4.2.orig/wscript
++++ node-v0.4.2/wscript
+@@ -436,7 +436,6 @@
+ # LFS
+ conf.env.append_value('CPPFLAGS', '-D_LARGEFILE_SOURCE')
+ conf.env.append_value('CPPFLAGS', '-D_FILE_OFFSET_BITS=64')
+- conf.env.append_value('CPPFLAGS', '-DEV_MULTIPLICITY=0')
+
+ # Makes select on windows support more than 64 FDs
+ if sys.platform.startswith("win32"):
diff --git a/testing/nodejs/nodejs-uclibc.patch b/testing/nodejs/nodejs-uclibc.patch
new file mode 100644
index 000000000..68fadff06
--- /dev/null
+++ b/testing/nodejs/nodejs-uclibc.patch
@@ -0,0 +1,20 @@
+--- node-v0.4.2.orig/deps/v8/src/platform-linux.cc
++++ node-v0.4.2/deps/v8/src/platform-linux.cc
+@@ -46,7 +46,7 @@
+ #include <sys/stat.h> // open
+ #include <fcntl.h> // open
+ #include <unistd.h> // sysconf
+-#ifdef __GLIBC__
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ #include <execinfo.h> // backtrace, backtrace_symbols
+ #endif // def __GLIBC__
+ #include <strings.h> // index
+@@ -447,7 +447,7 @@
+
+ int OS::StackWalk(Vector<OS::StackFrame> frames) {
+ // backtrace is a glibc extension.
+-#ifdef __GLIBC__
++#if defined(__GLIBC__) && !defined(__UCLIBC__)
+ int frames_size = frames.length();
+ ScopedVector<void*> addresses(frames_size);
+
diff --git a/testing/tzdata/APKBUILD b/testing/tzdata/APKBUILD
index 4c10a39ab..eec6b8bb9 100644
--- a/testing/tzdata/APKBUILD
+++ b/testing/tzdata/APKBUILD
@@ -2,7 +2,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=tzdata
pkgver=2011c
-pkgrel=0
+_ptzver=0.1
+pkgrel=1
pkgdesc="Timezone data"
url="http://www.twinsun.com/tz/tz-link.htm"
arch="all"
@@ -13,6 +14,7 @@ install=
subpackages="$pkgname-doc"
source="ftp://elsie.nci.nih.gov/pub/tzcode$pkgver.tar.gz
ftp://elsie.nci.nih.gov/pub/tzdata$pkgver.tar.gz
+ http://git.alpinelinux.org/cgit/ncopa/posixtz.git/snapshot/posixtz-$_ptzver.tar.bz2
Makefile.patch"
_builddir="$srcdir"
@@ -29,14 +31,21 @@ prepare() {
build() {
cd "$_builddir"
make || return 1
+
+ cd "$srcdir"/posixtz-$_ptzver
+ make posixtz
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/share/zoneinfo/localtime
+
+ install -Dm755 "$srcdir"/posixtz-$_ptzver/posixtz \
+ "$pkgdir"/usr/bin/posixtz
}
md5sums="35c09d1cd46c1f40985562334521a7e5 tzcode2011c.tar.gz
1a01b1a3346c1531daab4970d0a2cd14 tzdata2011c.tar.gz
+be1ca94f79abfa367b4c54a51737ba91 posixtz-0.1.tar.bz2
a64ed97d1fc03c66ee8612c0d9f40507 Makefile.patch"