summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-01-13 13:19:43 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-01-13 13:20:00 +0000
commit71b6c9cdd26586ba96a21130e841b54ea593d0fb (patch)
treedfbb088e3f19fb9099c2311f9c002dfaa268010d
parent4faf5a177cc4cc276bb6a16627d9350041c21696 (diff)
downloadaports-71b6c9cdd26586ba96a21130e841b54ea593d0fb.tar.bz2
aports-71b6c9cdd26586ba96a21130e841b54ea593d0fb.tar.xz
main/ppp: fix musl build
-rw-r--r--main/ppp/APKBUILD25
-rw-r--r--main/ppp/musl-fix-headers.patch123
2 files changed, 147 insertions, 1 deletions
diff --git a/main/ppp/APKBUILD b/main/ppp/APKBUILD
index 57cc8966a..d1d662ae6 100644
--- a/main/ppp/APKBUILD
+++ b/main/ppp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ppp
pkgver=2.4.5
-pkgrel=7
+pkgrel=8
pkgdesc="A daemon which implements the PPP protocol for dial-up networking"
url="http://www.samba.org/ppp/"
arch="all"
@@ -11,6 +11,8 @@ makedepends="libpcap-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="ftp://ftp.samba.org/pub/$pkgname/$pkgname-$pkgver.tar.gz
defaultroute-metric.3.patch
+ musl-fix-headers.patch
+
options
pon
poff
@@ -74,6 +76,7 @@ package() {
}
md5sums="4621bc56167b6953ec4071043fe0ec57 ppp-2.4.5.tar.gz
e26f807a61490fedbc9a7632caebd973 defaultroute-metric.3.patch
+a1fde30d2ae6e7e6fcef470afc90d13f musl-fix-headers.patch
9185f645bb433b22a9951d9d12f79c35 options
48c024f73a80c8b69c4def22f86902cc pon
2d811f8470ccdea3b8c4505a438483e9 poff
@@ -81,3 +84,23 @@ e26f807a61490fedbc9a7632caebd973 defaultroute-metric.3.patch
44cc662ba9aa61dd9add3ddd4c5ded57 pon.1
fac0c773490371ea673f4be0977a230f ip-up
a88b40b1bf91eb5cca3762b7195e4fe2 ip-down"
+sha256sums="43317afec9299f9920b96f840414c977f0385410202d48e56d2fdb8230003505 ppp-2.4.5.tar.gz
+b6b01f0022120d4575359663b03518e630aa671b11695f2e20776a83f62228e6 defaultroute-metric.3.patch
+32bff6e2ffc34677f483d6d7860851270251fb3ce935fcffc7126bfaad10d26d musl-fix-headers.patch
+9f473800a48bbaec41b465817ae9c4c53d6b0ce865b4298d9353b30707a39605 options
+c92e0721c4f53987dd0a02fe7089d0f5a58cdb7bb9f26d1bddc28111406ce6c2 pon
+ee1e1e5f164effe49bc7ffab3fbde6efbd46d186c58192913f749257026d75e2 poff
+43608081ab9d6a755eb4e6fa2011f88b16b1702745d76bced6d546a7c579b39f plog
+9bb35eac78898cdc75184bb70fea11fb2e2889e1e2cadf0b7bb8320d7cae0959 pon.1
+7d44e21ed945434c32a385f44c690826f74c3d5ddac353deae8174692d8d1beb ip-up
+84f2b44c9f4b8abdbc9cfbfffb669fa19385b80da55f9c292df115189dc62bd6 ip-down"
+sha512sums="3688720a0f9ee47802e72dc6aa3d47c7312c195007f37a6ceb087fdb6f1f77ad75e922a568cffed6d1a857f06d79460d6d38b56e179310e493a0380a0c5a4f6e ppp-2.4.5.tar.gz
+135cd073f1a1b6a1213f87b4d201dc3a298f40c0474ecc3ef0bd01bf61f8273d94e22b5a38b54dfa8d5315a64fc53a0bec3bb68123881ea6bb2c22ef759ccd21 defaultroute-metric.3.patch
+9423da37d3b002ff0b554419b293bc8507f1c6d0404dfed42bb37194b981a4927ee7cef62798e31b14e46693c6c4a5c1986876c3fafb798e160d99f92601d23c musl-fix-headers.patch
+cabcaa8d44f0da399326b7f93267d4786b32f69c6fa7a78ab451575a8cc594f2a259406166c874d88ecfc0861b8b4abdb3b653cf1cb00e2f2838ea880962f6ee options
+29233c8010f511792c2dcf54ee06ede271994ef029b6b526aeeb17433233ef6b638b96346d81db55c2a6bb25fb07633328415cd3af55dadd78a32b1d45b07dd8 pon
+3605ce49bad21473ef5f3ff2421e1ef7687e9267986503deca63ae3a2baa6308e8d031cb1da2f93b5b73dc292206a49c59cea17b80c129272cc975e07e3c6142 poff
+f40ab2549c2e05adc018197911c4820187aa5e9920004b0b1d68ebf38688a1fcab1f79966eb73f36237ec84f056ab9e0c05e32cbfd73fdd0c368216cf54741fd plog
+c5dc475940a34a2b489279f89d9b428b0e811abb6b22ef53b926784ab39e92981cd1eab79f8ff0c91de618c3bf890701fd7a8138537cdb036f8771e7ca16b5c4 pon.1
+8258c95a6b6e8e94d6001b5cd3a99bd3270f29ba0f2e5050a26c8d5f1b67eead8d039e71ce86a784d45e620047b0a2bb14b258d80a9ea62084ba588a4c2e2d84 ip-up
+160260bd2a788beaac395eadb38efbfd1e0e1a458fe151555acacf2c4f3a12381d644672c664f9793db6e3459a4f05a54e3ff6d407b0d37e8014b15bd0f11bcc ip-down"
diff --git a/main/ppp/musl-fix-headers.patch b/main/ppp/musl-fix-headers.patch
new file mode 100644
index 000000000..6a43cc0fd
--- /dev/null
+++ b/main/ppp/musl-fix-headers.patch
@@ -0,0 +1,123 @@
+--- ppp-2.4.5.orig/include/net/ppp_defs.h
++++ ppp-2.4.5/include/net/ppp_defs.h
+@@ -38,6 +38,8 @@
+ #ifndef _PPP_DEFS_H_
+ #define _PPP_DEFS_H_
+
++#include <sys/time.h>
++
+ /*
+ * The basic PPP frame.
+ */
+--- ppp-2.4.5.orig/pppd/ipv6cp.c
++++ ppp-2.4.5/pppd/ipv6cp.c
+@@ -151,6 +151,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+ #include <netdb.h>
+--- ppp-2.4.5.orig/pppd/magic.h
++++ ppp-2.4.5/pppd/magic.h
+@@ -42,6 +42,8 @@
+ * $Id: magic.h,v 1.5 2003/06/11 23:56:26 paulus Exp $
+ */
+
++#include <sys/cdefs.h>
++
+ void magic_init __P((void)); /* Initialize the magic number generator */
+ u_int32_t magic __P((void)); /* Returns the next magic number */
+
+--- ppp-2.4.5.orig/pppd/sys-linux.c
++++ ppp-2.4.5/pppd/sys-linux.c
+@@ -102,19 +102,11 @@
+ #define MAX_ADDR_LEN 7
+ #endif
+
+-#if __GLIBC__ >= 2
+ #include <asm/types.h> /* glibc 2 conflicts with linux/types.h */
+ #include <net/if.h>
+ #include <net/if_arp.h>
+ #include <net/route.h>
+ #include <netinet/if_ether.h>
+-#else
+-#include <linux/types.h>
+-#include <linux/if.h>
+-#include <linux/if_arp.h>
+-#include <linux/route.h>
+-#include <linux/if_ether.h>
+-#endif
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+
+--- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/if.c
++++ ppp-2.4.5/pppd/plugins/rp-pppoe/if.c
+@@ -30,10 +30,6 @@
+ #include <linux/if_packet.h>
+ #endif
+
+-#ifdef HAVE_NET_ETHERNET_H
+-#include <net/ethernet.h>
+-#endif
+-
+ #ifdef HAVE_ASM_TYPES_H
+ #include <asm/types.h>
+ #endif
+--- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/plugin.c
++++ ppp-2.4.5/pppd/plugins/rp-pppoe/plugin.c
+@@ -46,7 +46,6 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <signal.h>
+-#include <net/ethernet.h>
+ #include <net/if_arp.h>
+ #include <linux/ppp_defs.h>
+ #include <linux/if_ppp.h>
+--- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/pppoe-discovery.c
++++ ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe-discovery.c
+@@ -27,10 +27,6 @@
+ #include <linux/if_packet.h>
+ #endif
+
+-#ifdef HAVE_NET_ETHERNET_H
+-#include <net/ethernet.h>
+-#endif
+-
+ #ifdef HAVE_ASM_TYPES_H
+ #include <asm/types.h>
+ #endif
+--- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/pppoe.h
++++ ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe.h
+@@ -86,18 +86,6 @@
+
+ #include <netinet/in.h>
+
+-#ifdef HAVE_NETINET_IF_ETHER_H
+-#include <sys/types.h>
+-
+-#ifdef HAVE_SYS_SOCKET_H
+-#include <sys/socket.h>
+-#endif
+-#ifndef HAVE_SYS_DLPI_H
+-#include <netinet/if_ether.h>
+-#endif
+-#endif
+-
+-
+
+ /* Ethernet frame types according to RFC 2516 */
+ #define ETH_PPPOE_DISCOVERY 0x8863
+Only in ppp-2.4.5/pppd/plugins/rp-pppoe: pppoe-discovery
+--- ppp-2.4.5.orig/pppd/plugins/rp-pppoe/pppoe-discovery.c
++++ ppp-2.4.5/pppd/plugins/rp-pppoe/pppoe-discovery.c
+@@ -51,6 +51,8 @@
+ exit(status);
+ }
+
++#define error(x...) fprintf(stderr, x)
++
+ /* Initialize frame types to RFC 2516 values. Some broken peers apparently
+ use different frame types... sigh... */
+