summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2012-01-27 11:55:09 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2012-01-27 11:56:06 +0000
commitae1c8570807704c0e8ebc8fb4db52872fd098607 (patch)
tree541a8485bbbc8e92c3e4cb5c2575a637e1fb6e6e
parenta8253aa765a6e2332cd2c05a3201ad2d9fd26aa8 (diff)
downloadaports-ae1c8570807704c0e8ebc8fb4db52872fd098607.tar.bz2
aports-ae1c8570807704c0e8ebc8fb4db52872fd098607.tar.xz
main/linux-scst: remove pre from scst kernel version
-rw-r--r--main/linux-scst/APKBUILD4
-rw-r--r--main/linux-scst/scst-2.2.0-3.2.2.patch8
2 files changed, 6 insertions, 6 deletions
diff --git a/main/linux-scst/APKBUILD b/main/linux-scst/APKBUILD
index 62da4613b..80fc87c7f 100644
--- a/main/linux-scst/APKBUILD
+++ b/main/linux-scst/APKBUILD
@@ -12,7 +12,7 @@ else
_kernver=${pkgver%.*}
fi
-pkgrel=0
+pkgrel=1
pkgdesc="Linux kernel with SCST"
url="http://scst.sourceforge.net"
depends="mkinitfs linux-firmware"
@@ -134,4 +134,4 @@ dev() {
md5sums="7ceb61f87c097fc17509844b71268935 linux-3.2.tar.bz2
e9e53fba37c5e2afa4cdecab234120bd patch-3.2.2.bz2
ef1fc8a0f776a9639a135ac58acd26ce kernelconfig.x86_64
-da058cfd855d01f71443370d846ea541 scst-2.2.0-3.2.2.patch"
+7fc262466073cc46e51630a2ca55eada scst-2.2.0-3.2.2.patch"
diff --git a/main/linux-scst/scst-2.2.0-3.2.2.patch b/main/linux-scst/scst-2.2.0-3.2.2.patch
index a6fef8db2..68e90a791 100644
--- a/main/linux-scst/scst-2.2.0-3.2.2.patch
+++ b/main/linux-scst/scst-2.2.0-3.2.2.patch
@@ -5045,7 +5045,7 @@ diff -uprN orig/linux-3.2/include/scst/scst_const.h linux-3.2/include/scst/scst_
+#define SCST_VERSION(a, b, c, d) (((a) << 24) + ((b) << 16) + ((c) << 8) + d)
+#define SCST_VERSION_CODE SCST_VERSION(2, 2, 0, 0)
+#define SCST_VERSION_STRING_SUFFIX
-+#define SCST_VERSION_NAME "2.2.0-pre"
++#define SCST_VERSION_NAME "2.2.0"
+#define SCST_VERSION_STRING SCST_VERSION_NAME SCST_VERSION_STRING_SUFFIX
+
+#define SCST_CONST_VERSION "$Revision: 3987 $"
@@ -54075,7 +54075,7 @@ diff -uprN orig/linux-3.2/include/scst/iscsi_scst_ver.h linux-3.2/include/scst/i
+
+#define ISCSI_VERSION_STRING_SUFFIX
+
-+#define ISCSI_VERSION_STRING "2.2.0-pre" ISCSI_VERSION_STRING_SUFFIX
++#define ISCSI_VERSION_STRING "2.2.0" ISCSI_VERSION_STRING_SUFFIX
diff -uprN orig/linux-3.2/include/scst/iscsi_scst_itf_ver.h linux-3.2/include/scst/iscsi_scst_itf_ver.h
--- orig/linux-3.2/include/scst/iscsi_scst_itf_ver.h
+++ linux-3.2/include/scst/iscsi_scst_itf_ver.h
@@ -73598,7 +73598,7 @@ diff -uprN orig/linux-3.2/drivers/scst/qla2xxx-target/qla2x00t.h linux-3.2/drive
+/* Version numbers, the same as for the kernel */
+#define Q2T_VERSION(a, b, c, d) (((a) << 030) + ((b) << 020) + (c) << 010 + (d))
+#define Q2T_VERSION_CODE Q2T_VERSION(2, 2, 0, 0)
-+#define Q2T_VERSION_STRING "2.2.0-pre"
++#define Q2T_VERSION_STRING "2.2.0"
+#define Q2T_PROC_VERSION_NAME "version"
+
+#define Q2T_MAX_CDB_LEN 16
@@ -79363,7 +79363,7 @@ diff -uprN orig/linux-3.2/drivers/scst/scst_local/scst_local.c linux-3.2/drivers
+static unsigned long scst_local_trace_flag = SCST_LOCAL_DEFAULT_LOG_FLAGS;
+#endif
+
-+#define SCST_LOCAL_VERSION "2.2.0-pre"
++#define SCST_LOCAL_VERSION "2.2.0"
+static const char *scst_local_version_date = "20110901";
+
+/* Some statistics */