summaryrefslogtreecommitdiffstats
path: root/main/abuild
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-07-12 12:08:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-12 12:08:30 +0000
commit8f6d5f7df8924178bb5dba5e519d6577e0044922 (patch)
tree40526b66972cfca101b8ce1eb73e486db17d478f /main/abuild
parent40563578200c6604c9fd0261769f67be710e1942 (diff)
downloadaports-8f6d5f7df8924178bb5dba5e519d6577e0044922.tar.bz2
aports-8f6d5f7df8924178bb5dba5e519d6577e0044922.tar.xz
main/abuild: depend on curl unless crosscompile
Diffstat (limited to 'main/abuild')
-rw-r--r--main/abuild/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/abuild/APKBUILD b/main/abuild/APKBUILD
index 43b3a9f3a..965d9dc94 100644
--- a/main/abuild/APKBUILD
+++ b/main/abuild/APKBUILD
@@ -3,10 +3,13 @@ pkgdesc="Script to build Alpine Packages"
pkgname=abuild
pkgver=2.15.0
_ver=${pkgver%_git*}
-pkgrel=0
+pkgrel=1
url=http://git.alpinelinux.org/cgit/abuild/
depends="fakeroot sudo pax-utils openssl apk-tools>=2.0.7-r1 abuildhelper
libc-utils"
+if [ "$CBUILD" = "$CHOST" ]; then
+ depends="$depends curl"
+fi
makedepends="openssl-dev pkgconfig"
install="$pkgname.pre-install $pkgname.pre-upgrade"
subpackages="apkbuild-cpan:cpan"