summaryrefslogtreecommitdiffstats
path: root/main/asterisk-audio-konf
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2010-08-20 14:20:08 +0300
committerTimo Teräs <timo.teras@iki.fi>2010-08-20 14:21:13 +0300
commit1e33b7eab5f93075308e651c0be053bd3a572a3b (patch)
tree59317db56fe7fc48ae635c6af7bef0c5d65f4f17 /main/asterisk-audio-konf
parent17c5dc11a5c75603a60ec814815508f5729a1e14 (diff)
downloadaports-1e33b7eab5f93075308e651c0be053bd3a572a3b.tar.bz2
aports-1e33b7eab5f93075308e651c0be053bd3a572a3b.tar.xz
main/asterisk-audio-konf: patch to fix handling of certain errors
Fixes conference application to return control to dialplan when non-fatal error happens.
Diffstat (limited to 'main/asterisk-audio-konf')
-rw-r--r--main/asterisk-audio-konf/0002-member-do-not-exit-with-error-if-join_conference-fai.patch38
-rw-r--r--main/asterisk-audio-konf/APKBUILD6
2 files changed, 42 insertions, 2 deletions
diff --git a/main/asterisk-audio-konf/0002-member-do-not-exit-with-error-if-join_conference-fai.patch b/main/asterisk-audio-konf/0002-member-do-not-exit-with-error-if-join_conference-fai.patch
new file mode 100644
index 000000000..aa5e3629e
--- /dev/null
+++ b/main/asterisk-audio-konf/0002-member-do-not-exit-with-error-if-join_conference-fai.patch
@@ -0,0 +1,38 @@
+From 287bb3324652e0e3086eefa62a6a1593331c9143 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 20 Aug 2010 14:14:22 +0300
+Subject: [PATCH] member: do not exit with error if join_conference() fails
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This causes Asterisk to hangup the call, but it was not intended
+as join_conference() sets dialplan variable properly to indicate
+error.
+
+Signed-off-by: Timo Teräs <timo.teras@iki.fi>
+---
+ konference/member.c | 3 +--
+ 1 files changed, 1 insertions(+), 2 deletions(-)
+
+diff --git a/konference/member.c b/konference/member.c
+index 863e34d..5370e73 100644
+--- a/konference/member.c
++++ b/konference/member.c
+@@ -755,12 +755,11 @@ int member_exec( struct ast_channel* chan, void* data )
+ //
+
+ conf = join_conference( member, recfile, recformat ) ;
+-
+ if ( conf == NULL )
+ {
+ ast_log( LOG_NOTICE, "unable to setup member conference %s\n", member->conf_name) ;
+ delete_member( member) ;
+- return -1;
++ return 0;
+ }
+
+ //
+--
+1.7.0.4
+
diff --git a/main/asterisk-audio-konf/APKBUILD b/main/asterisk-audio-konf/APKBUILD
index cd87e2780..3025b873c 100644
--- a/main/asterisk-audio-konf/APKBUILD
+++ b/main/asterisk-audio-konf/APKBUILD
@@ -4,7 +4,7 @@ pkgname=asterisk-audio-konf
_basever=0
_gitver=100607
pkgver=${_basever}_git${_gitver}
-pkgrel=0
+pkgrel=1
pkgdesc="A fork of AppKonference focused entirely on audio conferencing"
url="http://github.com/jthomerson/AsteriskAudioKonf/"
license="GPL"
@@ -15,6 +15,7 @@ subpackages=
_snapfile="$pkgname-$pkgver.tar.bz2"
source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
0001-add-n-flag-to-prevent-dynamic-create-of-conference.patch
+ 0002-member-do-not-exit-with-error-if-join_conference-fai.patch
"
_gitver=100607
@@ -64,4 +65,5 @@ package() {
}
md5sums="8a716a2d1daa622f86a485804e403571 asterisk-audio-konf-0_git100607.tar.bz2
-937afbb9fa2ce57615f09919e15ab2d3 0001-add-n-flag-to-prevent-dynamic-create-of-conference.patch"
+937afbb9fa2ce57615f09919e15ab2d3 0001-add-n-flag-to-prevent-dynamic-create-of-conference.patch
+2d0d8bf20b2a22bd099f1461cfd1fe27 0002-member-do-not-exit-with-error-if-join_conference-fai.patch"