summaryrefslogtreecommitdiffstats
path: root/main/bash
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-03-12 16:07:59 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-03-12 16:07:59 +0000
commitc30d92b021bf603038177f4d28da28046da04322 (patch)
tree32a45487c053caacbc8ff39f655d0ce4d6f8f34d /main/bash
parent5d46ab6d1b715872a0043cabdea887f8bda15a0c (diff)
downloadaports-c30d92b021bf603038177f4d28da28046da04322.tar.bz2
aports-c30d92b021bf603038177f4d28da28046da04322.tar.xz
main/bash: upgrade to 4.1.002
Diffstat (limited to 'main/bash')
-rw-r--r--main/bash/APKBUILD118
1 files changed, 31 insertions, 87 deletions
diff --git a/main/bash/APKBUILD b/main/bash/APKBUILD
index e318a53e9..d6efe92b0 100644
--- a/main/bash/APKBUILD
+++ b/main/bash/APKBUILD
@@ -1,74 +1,51 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bash
-_myver=4.0
-_patchbase=40
-_patchlevel=035
-pkgver=4.0.035
+pkgver=4.1.002
+_patchlevel=${pkgver##*.}
+_myver=${pkgver%.*}
+_patchbase=${_myver%.*}${_myver#*.}
pkgrel=0
pkgdesc="The GNU Bourne Again shell"
license='GPL'
url="http://www.gnu.org/software/bash/bash.html"
makedepends="readline-dev ncurses-dev bison flex"
depends=
+subpackages="$pkgname-doc"
source="http://ftp.gnu.org/gnu/bash/bash-${_myver}.tar.gz
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-001
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-002
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-003
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-004
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-005
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-006
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-007
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-008
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-009
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-010
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-011
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-012
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-013
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-014
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-015
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-016
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-017
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-018
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-019
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-020
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-021
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-022
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-023
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-024
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-025
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-026
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-027
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-028
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-029
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-030
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-031
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-032
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-033
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-034
- http://ftp.gnu.org/gnu/bash/bash-4.0-patches/bash40-035
bash-noinfo.patch
"
-
-subpackages="$pkgname-doc"
+# generate url's to patches. note: no forks allowed!
+_i=1
+_pad="00"
+while [ $_i -le $_patchlevel ]; do
+ [ $_i -ge 10 ] && _pad="0"
+ [ $_i -ge 100 ] && _pad=
+ source="$source http://ftp.gnu.org/gnu/bash/bash-$_myver-patches/bash$_patchbase-$_pad$_i"
+ _i=$(( $_i + 1))
+done
# run 'abuild _gensrc >> APKBUILD' to generate the patch list
-_gensrc() {
- for _i in $(seq 1 $_patchlevel); do
- # seq -w unsupported by busybox
- _p=$(printf "%0.3i" $_i)
- echo -e "\thttp://ftp.gnu.org/gnu/bash/bash-${_myver}-patches/bash${_patchbase}-$_p"
- done
-}
+#_gensrc() {
+# for _i in $(seq 1 $_patchlevel); do
+# # seq -w unsupported by busybox
+# _p=$(printf "%0.3i" $_i)
+# echo -e "\thttp://ftp.gnu.org/gnu/bash/bash-${_myver}-patches/bash${_patchbase}-$_p"
+# done
+#}
-build() {
+_builddir="$srcdir"/$pkgname-$_myver
+prepare() {
local p
- cd ${startdir}/src/${pkgname}-${_myver}
+ cd "$_builddir"
for p in ../bash${_patchbase}-??? ../*.patch; do
msg "applying patch ${p##*/}"
patch -p0 -i $p || return 1
done
+}
+build() {
+ cd "$_builddir"
./configure --prefix=/usr \
--with-curses \
--disable-nls \
@@ -87,40 +64,7 @@ package() {
rm -rf "$pkgdir"/usr/share/locale
}
-md5sums="a90a1b5a6db4838483f05438e05e8eb9 bash-4.0.tar.gz
-bc7f4762443939bd7dccb42370f0d932 bash40-001
-c2a4a4786a83ed4ec366c6a8924369a2 bash40-002
-22e8a824eddba21a8fce10d7984c2aba bash40-003
-ed7cbced8c7c964323265522369a37a2 bash40-004
-8ed86b7d31423d71ecf3148251d63512 bash40-005
-5f447338cb98ff156cabf1fd9879d5f3 bash40-006
-96e946cb66a4ca186cba1da44f1ee163 bash40-007
-d3eb7b6f00d525e032478c33f51d46a8 bash40-008
-340601c997ce569532417a7ae92248b8 bash40-009
-0bd5ab96d514ffb1afbb8c7984b15146 bash40-010
-32cb20f339a20e1e9fb37a5d18f18fca bash40-011
-33fd9e93d30a17988c19554ef26d56e0 bash40-012
-a266b42df5e9ed7e8818a8b00d50e00b bash40-013
-86cac78f191a32cd1404f11264eb9b2a bash40-014
-bb41963d030bc61a20e8185367b337c5 bash40-015
-f75455048a086528971252fd979b8755 bash40-016
-34b2cd57271a452f4a26b39d77ff908f bash40-017
-99318eed8dcc05e10a14ae27043f175d bash40-018
-af3b9aaeadc71a5007bec2b98c751cde bash40-019
-eb7c7ddeb7e8451eb59228dca3329696 bash40-020
-585d701b978ceb63967dc020db3a2234 bash40-021
-7a70f2608f90f6ac0c2051e5f1c6c414 bash40-022
-7a23aa41630dd4fe8d30108a200e2d96 bash40-023
-82ba5fc9eb780eb57d8b7628a17b7d74 bash40-024
-b26f9007ac4eef5c378f1abcb8959025 bash40-025
-83bc844c82d0a30740e8d91a8238bfa9 bash40-026
-a41c187f05ecab07389c18acc91214c6 bash40-027
-fcc367e6471267d2e397257e703b817d bash40-028
-4d4da1c0be8dfee8e2a6a7703901130f bash40-029
-55cbdc8e5173d7d59bf1113c3ff590dc bash40-030
-389635281133416de9d13295251cabc7 bash40-031
-d646cb4aed8e0f0d1d47eea2ed5f3690 bash40-032
-d3e77d2a0a051478aca8c30d13ded834 bash40-033
-05a54807fd388e71bac8912ad530ac6d bash40-034
-fc3d8fdb83ccc407ab7f6d1b7ac6a221 bash40-035
-80fec5f3d60a63756a4999c877e31a8e bash-noinfo.patch"
+md5sums="9800d8724815fd84994d9be65ab5e7b8 bash-4.1.tar.gz
+80fec5f3d60a63756a4999c877e31a8e bash-noinfo.patch
+582dea5671b557f783e18629c2f77b68 bash41-001
+118d465095d4a4706eb1d34696a2666a bash41-002"