summaryrefslogtreecommitdiffstats
path: root/main/bluez
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-03 07:50:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-03 07:50:58 +0000
commitb689da87298cbd9e2be38c35a8548fe9f97e52d8 (patch)
tree125a0c009b3ad410ff7883e7d4cbf2fc2a08f501 /main/bluez
parentb4097755f3c8a80331fb5298e1dbdd44f89b5e74 (diff)
downloadaports-b689da87298cbd9e2be38c35a8548fe9f97e52d8.tar.bz2
aports-b689da87298cbd9e2be38c35a8548fe9f97e52d8.tar.xz
main/bluez: update init.d scripts, split hid2hci
the udev rules to start up bluetoothd rules have been removed from upstream. http://git.kernel.org/?p=bluetooth/bluez.git;a=commit;h=2ea98a6a043710ad4958355b62c682b4767f292e
Diffstat (limited to 'main/bluez')
-rw-r--r--main/bluez/APKBUILD24
-rw-r--r--main/bluez/bluetooth.confd7
-rw-r--r--main/bluez/bluetooth.initd28
-rw-r--r--main/bluez/rfcomm.confd (renamed from main/bluez/bluetooth-conf.d)2
-rw-r--r--main/bluez/rfcomm.initd (renamed from main/bluez/bluetooth-init.d)18
5 files changed, 27 insertions, 52 deletions
diff --git a/main/bluez/APKBUILD b/main/bluez/APKBUILD
index 3cfe01deb..6707ba324 100644
--- a/main/bluez/APKBUILD
+++ b/main/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
pkgver=4.101
-pkgrel=0
+pkgrel=1
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
arch="all"
@@ -11,10 +11,11 @@ replaces="udev"
makedepends="dbus-dev gst-plugins-base-dev alsa-lib-dev libusb-compat-dev
libnl-dev consolekit-dev udev-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-alsa
- $pkgname-cups $pkgname-gstreamer"
+ $pkgname-cups $pkgname-gstreamer $pkgname-hid2hci"
source="http://www.kernel.org/pub/linux/bluetooth/$pkgname-$pkgver.tar.bz2
bluetooth.initd
- bluetooth.confd
+ rfcomm.initd
+ rfcomm.confd
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -23,7 +24,6 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --libexecdir=/lib \
--mandir=/usr/share/man \
--enable-gstreamer \
--enable-alsa \
@@ -46,7 +46,8 @@ package() {
rm "$pkgdir"/usr/lib/*/*.la \
"$pkgdir"/usr/lib/*.la || return 1
install -Dm755 "$srcdir"/bluetooth.initd "$pkgdir"/etc/init.d/bluetooth
- install -Dm644 "$srcdir"/bluetooth.confd "$pkgdir"/etc/conf.d/bluetooth
+ install -Dm755 "$srcdir"/rfcomm.initd "$pkgdir"/etc/init.d/rfcomm
+ install -Dm644 "$srcdir"/rfcomm.confd "$pkgdir"/etc/conf.d/rfcomm
install -Dm755 test/simple-agent "$pkgdir"/usr/bin/bluez-simple-agent
}
@@ -75,6 +76,15 @@ gstreamer() {
mv "$pkgdir"/usr/lib/gstreamer* \
"$subpkgdir"/usr/lib/
}
+
+hid2hci() {
+ pkgdesc="Put HID proxying bluetooth HCI's into HCI mode"
+ replaces="bluez"
+ mkdir -p "$subpkgdir"
+ mv "$pkgdir"/lib "$subpkgdir"/
+}
+
md5sums="902b390af95c6c5d6d1a17d94c8344ab bluez-4.101.tar.bz2
-c511078403d7d27673581a8bb468b90b bluetooth.initd
-a159d897a057f4675548327329c4cc22 bluetooth.confd"
+701636b72c4fb72b1d81a050471b130c bluetooth.initd
+7672edb8e33c4495ee9febb9864feb10 rfcomm.initd
+7f4bb093adb0f519c621f2ea68712f35 rfcomm.confd"
diff --git a/main/bluez/bluetooth.confd b/main/bluez/bluetooth.confd
deleted file mode 100644
index b0cc74441..000000000
--- a/main/bluez/bluetooth.confd
+++ /dev/null
@@ -1,7 +0,0 @@
-# Bluetooth configuraton file
-
-# Bind rfcomm devices (allowed values are "true" and "false")
-RFCOMM_ENABLE=true
-
-# Config file for rfcomm
-RFCOMM_CONFIG="/etc/bluetooth/rfcomm.conf"
diff --git a/main/bluez/bluetooth.initd b/main/bluez/bluetooth.initd
index ef25720bf..d9d5d9c91 100644
--- a/main/bluez/bluetooth.initd
+++ b/main/bluez/bluetooth.initd
@@ -1,32 +1,10 @@
#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/4.60/bluetooth-init.d,v 1.1 2010/02/01 19:47:46 pacho Exp $
+
+name="Bluetooth"
+command="/usr/sbin/bluetoothd"
depend() {
after coldplug
need dbus localmount
}
-start() {
- ebegin "Starting Bluetooth"
-
- if [ -x /sbin/udevadm ]; then
- udevadm trigger --subsystem-match=bluetooth --action=add
- eend $?
- fi
-
- if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
- if [ -f "${RFCOMM_CONFIG}" ]; then
- /usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
- else
- ewarn "Not enabling rfcomm because RFCOMM_CONFIG does not exists"
- fi
- fi
- eend $?
-}
-
-stop() {
- ebegin "Shutting down Bluetooth"
- eend 0
-}
diff --git a/main/bluez/bluetooth-conf.d b/main/bluez/rfcomm.confd
index b0cc74441..d87acdb28 100644
--- a/main/bluez/bluetooth-conf.d
+++ b/main/bluez/rfcomm.confd
@@ -1,5 +1,3 @@
-# Bluetooth configuraton file
-
# Bind rfcomm devices (allowed values are "true" and "false")
RFCOMM_ENABLE=true
diff --git a/main/bluez/bluetooth-init.d b/main/bluez/rfcomm.initd
index 111902aae..d3b819e1a 100644
--- a/main/bluez/bluetooth-init.d
+++ b/main/bluez/rfcomm.initd
@@ -1,22 +1,17 @@
#!/sbin/runscript
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/4.60/bluetooth-init.d,v 1.1 2010/02/01 19:47:46 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez/files/rfcomm-init.d,v 1.1 2011/12/31 21:09:18 pacho Exp $
depend() {
after coldplug
- need dbus localmount
+ need dbus localmount hostname
}
start() {
- ebegin "Starting Bluetooth"
-
- udevadm trigger --subsystem-match=bluetooth
- eend $?
-
if [ "${RFCOMM_ENABLE}" = "true" -a -x /usr/bin/rfcomm ]; then
if [ -f "${RFCOMM_CONFIG}" ]; then
- ebegin " Starting rfcomm"
+ ebegin "Starting rfcomm"
/usr/bin/rfcomm -f "${RFCOMM_CONFIG}" bind all
eend $?
else
@@ -26,6 +21,7 @@ start() {
}
stop() {
- ebegin "Shutting down Bluetooth"
- eend 0
+ ebegin "Shutting down rfcomm"
+ /usr/bin/rfcomm release all
+ eend $?
}