summaryrefslogtreecommitdiffstats
path: root/main/bonding
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-12 14:50:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-12 14:52:31 +0000
commit0a661e6030ef55bd0262bcbc1140107f06f73157 (patch)
treee4fa3a4640c5eec9d46ac0e0ee2295bff4e640fa /main/bonding
parent16adad70b228760742bd7f9e0bd1e3312e280201 (diff)
downloadaports-0a661e6030ef55bd0262bcbc1140107f06f73157.tar.bz2
aports-0a661e6030ef55bd0262bcbc1140107f06f73157.tar.xz
main/bonding: set link status to down
in case bonded interface is 'manual' ref #2219
Diffstat (limited to 'main/bonding')
-rw-r--r--main/bonding/APKBUILD10
-rwxr-xr-xmain/bonding/bonding.post-down5
2 files changed, 12 insertions, 3 deletions
diff --git a/main/bonding/APKBUILD b/main/bonding/APKBUILD
index 4cdb755f2..236240408 100644
--- a/main/bonding/APKBUILD
+++ b/main/bonding/APKBUILD
@@ -5,7 +5,7 @@
pkgname=bonding
pkgver=2.6
-pkgrel=2
+pkgrel=3
pkgdesc="Scripts for network interface bonding"
url="http://wiki.alpinelinux.org/wiki/Bonding"
arch="noarch"
@@ -40,4 +40,10 @@ package() {
md5sums="e5b1ba826edd950bcf7bedf8cd550e9e bonding.pre-up
68e64f483be3f8730a4c522f1e63e92d bonding.up
-c5f6d07415118aa21d8e4730f9f18cab bonding.post-down"
+f94e3a116adf466f6b801a320bdc53ca bonding.post-down"
+sha256sums="d8613d3ca76bc69545487fd9d50eb3f6b6c2e81e22c170236531d8e3f04d9eb9 bonding.pre-up
+237a571c9a1e36d9871764ea3415d7ab0d6718718a22549a0a4b14576ed21b6f bonding.up
+d24e1061ffd123d10cd9d19b00a70a46e54b7f98ee56cc1eb4b04c1fc2d72b8e bonding.post-down"
+sha512sums="88d0566242b172c60b66bd62ce1b5c9f01e5d3b79a2caa7eea8f2ec0255158f449392a54348dd5c375d14f4d8fa6182333c2154582c7eab7f3e8f4a7adce900a bonding.pre-up
+5c81b2891c281df2df4c98a560f776b857e4b6b20ac733858683d87fb7b1ac57423f57003cfdcfac24c8257de31062c4596270e9482b8d35d517e29f2bac0951 bonding.up
+c6b6f06d1c0a7be1022feb18cdcc55780cad2200ac0121f276527442becb7d75a7850b809ae9c6d5b914a1a03f791bd65c088f1289ce0e28b5a02bd86e3868de bonding.post-down"
diff --git a/main/bonding/bonding.post-down b/main/bonding/bonding.post-down
index 8dd4c07e9..5b62d8b92 100755
--- a/main/bonding/bonding.post-down
+++ b/main/bonding/bonding.post-down
@@ -19,7 +19,7 @@ sysfs_remove_all()
# Called with:
# $1 = target filename
read values < "/sys/class/net/$IFACE/bonding/$1"
- for value in $values ; do
+ for value in $values ; do
echo "-$value" > "/sys/class/net/$IFACE/bonding/$1"
done
}
@@ -62,3 +62,6 @@ for slave in $slaves ; do
echo "-$slave" > "$BOND_PARAMS/slaves" 2> /dev/null
fi
done
+
+# make sure that the link is set to down
+ip link set dev $IFACE down