summaryrefslogtreecommitdiffstats
path: root/main/checkbashisms
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-06 09:03:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-06 09:03:03 +0000
commit5ff951fb24d3e282132abb5f077040411f447f49 (patch)
treea5344b8c0985d1668bc2c8d7828b0e74b42053d7 /main/checkbashisms
parent73dd17638eb341748f14bf6dd570c49d348a0aa2 (diff)
downloadaports-5ff951fb24d3e282132abb5f077040411f447f49.tar.bz2
aports-5ff951fb24d3e282132abb5f077040411f447f49.tar.xz
main/checkbashisms: moved from testing
Diffstat (limited to 'main/checkbashisms')
-rw-r--r--main/checkbashisms/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/main/checkbashisms/APKBUILD b/main/checkbashisms/APKBUILD
new file mode 100644
index 000000000..05ec5b6b8
--- /dev/null
+++ b/main/checkbashisms/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Natanael Copa
+pkgname=checkbashisms
+pkgver=2.0.0.2
+pkgrel=0
+pkgdesc="Basic checks on shell scripts for the presence of non portable syntax"
+url="http://sourceforge.net/projects/checkbaskisms/"
+arch="noarch"
+license="GPL"
+depends="perl"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/project/checkbaskisms/$pkgver/checkbashisms"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 "$srcdir"/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+md5sums="1261d0c5aafedc15ab4405c1969deacf checkbashisms"