summaryrefslogtreecommitdiffstats
path: root/main/cmake
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-09 12:01:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-09 12:17:33 +0000
commit1a5858764095caca147ee8464457b231d22c80b8 (patch)
tree29b06a8ae4e5490c3418821c832088ee020ff942 /main/cmake
parentabc8209f0d460ef49a77e4c6706437e33a716200 (diff)
downloadaports-1a5858764095caca147ee8464457b231d22c80b8.tar.bz2
aports-1a5858764095caca147ee8464457b231d22c80b8.tar.xz
main/cmake: upgrade to 2.8.12
Diffstat (limited to 'main/cmake')
-rw-r--r--main/cmake/APKBUILD20
-rw-r--r--main/cmake/fix-execinfo.h-detection.patch11
2 files changed, 6 insertions, 25 deletions
diff --git a/main/cmake/APKBUILD b/main/cmake/APKBUILD
index 5a523e339..923d553c4 100644
--- a/main/cmake/APKBUILD
+++ b/main/cmake/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=cmake
-pkgver=2.8.11.2
-pkgrel=1
+pkgver=2.8.12
+pkgrel=0
pkgdesc="CMake is a cross-platform open-source make system"
url="http://www.cmake.org"
arch="all"
@@ -16,7 +16,7 @@ case $pkgver in
esac
source="http://www.cmake.org/files/$_v/cmake-${pkgver}.tar.gz
- fix-execinfo.h-detection.patch"
+ "
_builddir="$srcdir/$pkgname-$pkgver"
@@ -41,11 +41,6 @@ prepare() {
build() {
cd "$_builddir"
- # bug in cmake.
- # http://www.mail-archive.com/cmake@cmake.org/msg09515.html
-# export CC="gcc"
-# export CXX="g++"
-
./bootstrap --prefix=/usr \
--mandir=/share/man \
--docdir=/share/cmake-${pkgver%.*}/doc \
@@ -60,9 +55,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="6f5d7b8e7534a5d9e1a7664ba63cf882 cmake-2.8.11.2.tar.gz
-892a67b8d52f3fd81ffb2077e2292e7c fix-execinfo.h-detection.patch"
-sha256sums="b32acb483afdd14339941c6e4ec25f633d916a7a472653a0b00838771a6c0562 cmake-2.8.11.2.tar.gz
-fac853838e95c36d80f478402f21f0b0c2c76e93c7eb5070df0f84820ed74f64 fix-execinfo.h-detection.patch"
-sha512sums="05ac2293300bf15fdcf98f07dfa7b9862b117cd0d6f7e30c1995ecb8a3bfd94e2b7e778caaa05bc46bd88eca5afe7f6be38b1904275a9a2aeae562bfdbaeec94 cmake-2.8.11.2.tar.gz
-857ced87d530aa88875df9ff313fe5617368b7be8661030bb3e66537a5416a2151fa671a94e901a1db30f0b4ebe76de787ebdd237d181d893c269ac7530ac705 fix-execinfo.h-detection.patch"
+md5sums="105bc6d21cc2e9b6aff901e43c53afea cmake-2.8.12.tar.gz"
+sha256sums="d885ba10b2406ede59aa31a928df33c9d67fc01433202f7dd586999cfd0e0287 cmake-2.8.12.tar.gz"
+sha512sums="39d771fb4730693b19c567b7646f41ffa3d45f488a410b9e3724f42cca1139ce091fd7b8f26c09480d0100ceb49d23177bc01cd3665fdcfb53f29bf76a2dbd13 cmake-2.8.12.tar.gz"
diff --git a/main/cmake/fix-execinfo.h-detection.patch b/main/cmake/fix-execinfo.h-detection.patch
deleted file mode 100644
index 4fdf830cd..000000000
--- a/main/cmake/fix-execinfo.h-detection.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake-2.8.11.2/Source/kwsys/SystemInformation.cxx
-+++ cmake-2.8.11.2/Source/kwsys/SystemInformation.cxx
-@@ -130,7 +130,7 @@
- # define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
- # endif
- # endif
--# if defined(__GNUC__)
-+# if defined(__GNUC__) && defined(__GLIBC__)
- # include <execinfo.h>
- # if !(defined(__LSB_VERSION__) && __LSB_VERSION__ < 41)
- # define KWSYS_SYSTEMINFORMATION_HAVE_BACKTRACE