summaryrefslogtreecommitdiffstats
path: root/main/db
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-27 14:19:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-27 14:22:26 +0000
commit1751d6595597f1d9101cac04e54f20d95790f4f4 (patch)
treee895c3aa71985691256eca03cf4f7cdfeb0d966b /main/db
parentee152f9e0dce8017d033e01e018f1482d27e7e1d (diff)
downloadaports-1751d6595597f1d9101cac04e54f20d95790f4f4.tar.bz2
aports-1751d6595597f1d9101cac04e54f20d95790f4f4.tar.xz
main/[various]: fix build against musl (add update_config_sub)
Diffstat (limited to 'main/db')
-rw-r--r--main/db/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/main/db/APKBUILD b/main/db/APKBUILD
index d1c333e85..725aff033 100644
--- a/main/db/APKBUILD
+++ b/main/db/APKBUILD
@@ -15,8 +15,14 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-utils $pkgname-c++:cxx"
source="http://download.oracle.com/berkeley-db/db-$pkgver.tar.gz
"
+_builddir="$srcdir/db-$_ver"
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build () {
- cd "$srcdir"/db-$_ver
+ cd "$_builddir"
for i in ../patch.*; do
[ -r "$i" ] || continue
msg "Applying $i..."