summaryrefslogtreecommitdiffstats
path: root/main/doxygen
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-10-04 14:59:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-10-04 14:59:14 +0000
commit8822c38b19f60caa36de2368a5571f90d9f9dc39 (patch)
tree3e4e6bfd98ba4e0f7b035f657ec1829dd9909cc8 /main/doxygen
parentec14d55cfc9f3ee4d54f673e90153525791b7de0 (diff)
downloadaports-8822c38b19f60caa36de2368a5571f90d9f9dc39.tar.bz2
aports-8822c38b19f60caa36de2368a5571f90d9f9dc39.tar.xz
main/doxygen: moved from testing
Diffstat (limited to 'main/doxygen')
-rw-r--r--main/doxygen/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/main/doxygen/APKBUILD b/main/doxygen/APKBUILD
new file mode 100644
index 000000000..b1f8b0e5a
--- /dev/null
+++ b/main/doxygen/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=doxygen
+pkgver=1.7.1
+pkgrel=0
+pkgdesc="A documentation system for C++, C, Java, IDL and PHP"
+url="http://www.doxygen.org/"
+license="GPL"
+depends=""
+makedepends="flex bison coreutils perl libiconv-dev"
+subpackages="$pkgname-doc"
+source="ftp://ftp.stack.nl/pub/users/dimitri/doxygen-$pkgver.src.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+
+ sed -i -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
+ -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
+ -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
+ tmake/lib/*/tmake.conf \
+ || return 1
+
+ # Ensure we link to -liconv
+ for pro in */*.pro.in */*/*.pro.in; do
+ echo "unix:LIBS += -liconv" >> "${pro}"
+ done
+
+ # fix final DESTDIR issue
+ sed -i -e "s:\$(INSTALL):\$(DESTDIR)/\$(INSTALL):g" \
+ addon/doxywizard/Makefile.in || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export ECFLAGS="$CFLAGS" ECXXFLAGS="$CXXFLAGS" ELDFLAGS="$LDFLAGS"
+ ./configure --prefix /usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" MAN1DIR=share/man/man1 install
+}
+
+md5sums="13e76e10fb55581a16ee04de35c264f0 doxygen-1.7.1.src.tar.gz"