summaryrefslogtreecommitdiffstats
path: root/main/ebtables
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-30 13:01:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-30 13:01:50 +0000
commitb4f923d6215219a93bfe8e5295b0ebe7f660f836 (patch)
treea0f1451a039993ac6c40a936b13450bd747f7ffc /main/ebtables
parentebee816ebfa1647f8c716ec83d9ff3f411521825 (diff)
downloadaports-b4f923d6215219a93bfe8e5295b0ebe7f660f836.tar.bz2
aports-b4f923d6215219a93bfe8e5295b0ebe7f660f836.tar.xz
main/ebtables: upgrade to 2.0.10.2
Diffstat (limited to 'main/ebtables')
-rw-r--r--main/ebtables/0001-link-with-gcc.patch25
-rw-r--r--main/ebtables/APKBUILD25
2 files changed, 10 insertions, 40 deletions
diff --git a/main/ebtables/0001-link-with-gcc.patch b/main/ebtables/0001-link-with-gcc.patch
deleted file mode 100644
index 88aba09f3..000000000
--- a/main/ebtables/0001-link-with-gcc.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/Makefile Sun Jun 21 13:13:25 2009
-+++ b/Makefile Wed Oct 28 02:42:43 2009
-@@ -85,7 +85,7 @@
-
- .PHONY: libebtc
- libebtc: $(OBJECTS2)
-- $(LD) -shared -soname libebtc.so -o libebtc.so -lc $(OBJECTS2)
-+ $(CC) -shared -Wl,-soname,libebtc.so -o libebtc.so -lc $(OBJECTS2)
-
- ebtables: $(OBJECTS) ebtables-standalone.o libebtc
- $(CC) $(CFLAGS) $(CFLAGS_SH_LIB) -o $@ ebtables-standalone.o -I$(KERNEL_INCLUDES) -L. -Lextensions -lebtc $(EXT_LIBSI) \
-@@ -153,10 +153,13 @@
- tmp3:=$(shell printf $(PIPE) | sed 's/\//\\\//g')
- .PHONY: scripts
- scripts: ebtables-save ebtables.sysv ebtables-config
-+ mkdir -p $(DESTDIR)$(BINDIR)
- cat ebtables-save | sed 's/__EXEC_PATH__/$(tmp1)/g' > ebtables-save_
- install -m 0755 -o root -g root ebtables-save_ $(DESTDIR)$(BINDIR)/ebtables-save
-+ mkdir -p $(DESTDIR)$(INITDIR)
- cat ebtables.sysv | sed 's/__EXEC_PATH__/$(tmp1)/g' | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables.sysv_
- install -m 0755 -o root -g root ebtables.sysv_ $(DESTDIR)$(INITDIR)/ebtables
-+ mkdir -p $(DESTDIR)$(SYSCONFIGDIR)
- cat ebtables-config | sed 's/__SYSCONFIG__/$(tmp2)/g' > ebtables-config_
- install -m 0600 -o root -g root ebtables-config_ $(DESTDIR)$(SYSCONFIGDIR)/ebtables-config
- rm -f ebtables-save_ ebtables.sysv_ ebtables-config_
diff --git a/main/ebtables/APKBUILD b/main/ebtables/APKBUILD
index c7ae555f2..184081cc7 100644
--- a/main/ebtables/APKBUILD
+++ b/main/ebtables/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Andrew Manison <amanison@anselsystems.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ebtables
-pkgver=2.0.9.1
-_realver=v2.0.9-1
-pkgrel=3
+pkgver=2.0.10.2
+_realver=v${pkgver%.[0-9]}-${pkgver##*.}
+pkgrel=0
pkgdesc="Ethernet bridge tables - Linux Ethernet filter for the Linux bridge."
url="http://ebtables.sourceforge.net/"
arch="all"
@@ -13,27 +13,23 @@ makedepends=
install=
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$_realver.tar.gz
- 0001-link-with-gcc.patch
ebtables.initd
ebtables.confd"
prepare() {
cd "$srcdir"/$pkgname-$_realver
# patches
- for i in ../*.patch; do
- msg "Applying $i"
- if ! patch --verbose -p1 -i $i; then
- error "$i failed"
- return 1
- fi
+ for i in $source; do
+ case "$i" in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
done
-
sed -i -e "s,^MANDIR:=.*,MANDIR:=/usr/share/man," \
-e "s,^BINDIR:=.*,BINDIR:=/sbin," \
-e "s,^INITDIR:=.*,INITDIR:=/usr/share/doc/ebtables," \
-e "s,^SYSCONFIGDIR:=.*,SYSCONFIGDIR:=/usr/share/doc/ebtables,"\
-e "s,^LIBDIR:=.*,LIBDIR:=/usr/lib/\$(PROGNAME)," \
- -e "s/^CFLAGS:=/CFLAGS+=/" \
+ -e "s/^CFLAGS:=/CFLAGS?=/" \
-e "s,^CC:=,CC?=," Makefile
}
@@ -43,7 +39,7 @@ build() {
# This package uses _init functions to initialise extensions. With
# --as-needed this will not work.
export LDFLAGS="$LDFLAGS -Wl,--no-as-needed"
- make || return 1
+ make CFLAGS="$CFLAGS" || return 1
}
package() {
@@ -53,7 +49,6 @@ package() {
install -D -m644 ../ebtables.confd "$pkgdir"/etc/conf.d/ebtables
}
-md5sums="0e0c20adf2bba6d91dbd0b74a1a38c33 ebtables-v2.0.9-1.tar.gz
-91a565a5906dc1fd4103f03c6a88e0e1 0001-link-with-gcc.patch
+md5sums="c5ae7fb75810fd936a5445239e853fd8 ebtables-v2.0.10-2.tar.gz
92e13b3bc1d47d7c00636ebb78c905d5 ebtables.initd
285089ba2d846e72e321a12e3da3cc96 ebtables.confd"