summaryrefslogtreecommitdiffstats
path: root/main/evince
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-31 11:40:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-31 16:02:15 +0000
commit3f044c2fce409f125cb7cdb65eb883c06e1ee48f (patch)
treefb6dba9ce144b6cadbc2b6a5c0be425ceb703008 /main/evince
parentf7e58ef0db81635ad253a98368e2462588013b49 (diff)
downloadaports-3f044c2fce409f125cb7cdb65eb883c06e1ee48f.tar.bz2
aports-3f044c2fce409f125cb7cdb65eb883c06e1ee48f.tar.xz
main/evince: build fix for automake-1.13
Diffstat (limited to 'main/evince')
-rw-r--r--main/evince/APKBUILD8
-rw-r--r--main/evince/automake.patch10
2 files changed, 15 insertions, 3 deletions
diff --git a/main/evince/APKBUILD b/main/evince/APKBUILD
index 9ff63d4f4..8d1085c95 100644
--- a/main/evince/APKBUILD
+++ b/main/evince/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=evince
pkgver=2.32.0
-pkgrel=12
+pkgrel=13
pkgdesc="simple document viewer for GTK+"
url="http://projects.gnome.org/evince/"
arch="all"
@@ -27,6 +27,7 @@ source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}
evince-2.32.0-update-poppler.patch
evince-2.32.0-use-popup.patch
libice-underlinking.patch
+ automake.patch
"
_builddir="${srcdir}/${pkgname}-${pkgver}"
@@ -38,7 +39,7 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
- autoreconf
+ aclocal && automake --add-missing && autoconf
}
build() {
@@ -71,4 +72,5 @@ dd7c481578b472e65f947eae8ff94aff evince-2.32.0-pk-fonts.patch
b9def0a702de462adad4758ca9d96b0f evince-2.32.0-stop-spinner.patch
10630dcef4486c00e58ef93963b4177f evince-2.32.0-update-poppler.patch
7f8d43461c08e439a18c65571493ad98 evince-2.32.0-use-popup.patch
-be7141be70e1434f699c0a14998d7ef0 libice-underlinking.patch"
+be7141be70e1434f699c0a14998d7ef0 libice-underlinking.patch
+ce28cef176b306bcd9e4ed4824fe41eb automake.patch"
diff --git a/main/evince/automake.patch b/main/evince/automake.patch
new file mode 100644
index 000000000..9a927e3d7
--- /dev/null
+++ b/main/evince/automake.patch
@@ -0,0 +1,10 @@
+--- ./configure.ac.orig 2010-09-27 18:48:44.000000000 +0000
++++ ./configure.ac 2012-12-31 11:36:59.992071872 +0000
+@@ -57,7 +57,6 @@
+
+ AC_ISC_POSIX
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AM_PROG_CC_C_O
+ AC_PROG_CXX
+ AC_STDC_HEADERS