summaryrefslogtreecommitdiffstats
path: root/main/faenza-icon-theme
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-30 19:41:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-30 19:41:34 +0000
commit202fc11745294cd1d646c714d8bd32469dad99bd (patch)
tree8e1f238b2214b95697bf05a6b96f49a63a1ca782 /main/faenza-icon-theme
parent5ab0bb42cc3b9bd9ea9579e921658f521e602649 (diff)
downloadaports-202fc11745294cd1d646c714d8bd32469dad99bd.tar.bz2
aports-202fc11745294cd1d646c714d8bd32469dad99bd.tar.xz
main/faenza-icon-theme: moved from testing
Diffstat (limited to 'main/faenza-icon-theme')
-rw-r--r--main/faenza-icon-theme/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/main/faenza-icon-theme/APKBUILD b/main/faenza-icon-theme/APKBUILD
new file mode 100644
index 000000000..c34d10124
--- /dev/null
+++ b/main/faenza-icon-theme/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=faenza-icon-theme
+pkgver=0.8
+pkgrel=1
+pkgdesc="icons designed to go in tandem with equinox themes"
+arch="noarch"
+url="http://tiheum.deviantart.com/art/Faenza-Icons-173323228"
+license="GPL"
+depends=
+makedepends="wget"
+install=
+subpackages=
+source="https://launchpad.net/~tiheum/+archive/equinox/+files/faenza-icon-theme_$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+package() {
+ cd "$_builddir"
+
+ mkdir -p "$pkgdir"/usr/share/icons
+ cp -dpRf Faenza* "$pkgdir"/usr/share/icons
+
+ for i in 16 22 24 32 48; do
+ mv "$pkgdir"/usr/share/icons/Faenza/places/$i/start-here-gnome.png \
+ "$pkgdir"/usr/share/icons/Faenza/places/$i/start-here.png
+
+ mv "$pkgdir"/usr/share/icons/Faenza-Dark/places/$i/start-here-gnome.png \
+ "$pkgdir"/usr/share/icons/Faenza-Dark/places/$i/start-here.png
+ done
+
+ for i in scalable; do
+ mv "$pkgdir"/usr/share/icons/Faenza/places/$i/start-here-gnome.svg \
+ "$pkgdir"/usr/share/icons/Faenza/places/$i/start-here.svg
+
+ mv "$pkgdir"/usr/share/icons/Faenza-Dark/places/$i/start-here-gnome.svg \
+ "$pkgdir"/usr/share/icons/Faenza-Dark/places/$i/start-here.svg
+ done
+}
+
+md5sums="c4f87cf4105d2330a259296f8e73e709 faenza-icon-theme_0.8.tar.gz"