summaryrefslogtreecommitdiffstats
path: root/main/fakeroot
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-07-08 10:12:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-07-08 11:40:50 +0000
commit4cfcfce44e0a30aadea101c76ab5b609317ced9c (patch)
tree373f62caf2e2fb428ccf761141598ed696791026 /main/fakeroot
parent26168a99d24dd09d955ac4bab3332dc55ce07d29 (diff)
downloadaports-4cfcfce44e0a30aadea101c76ab5b609317ced9c.tar.bz2
aports-4cfcfce44e0a30aadea101c76ab5b609317ced9c.tar.xz
main/fakeroot: support crosscompiling and musl
Diffstat (limited to 'main/fakeroot')
-rw-r--r--main/fakeroot/APKBUILD19
1 files changed, 18 insertions, 1 deletions
diff --git a/main/fakeroot/APKBUILD b/main/fakeroot/APKBUILD
index ad70b901f..f9f8f0f12 100644
--- a/main/fakeroot/APKBUILD
+++ b/main/fakeroot/APKBUILD
@@ -24,7 +24,16 @@ prepare() {
build() {
cd $startdir/src/$pkgname-$pkgver
- CONFIG_SHELL=/bin/sh ./configure --prefix=/usr --disable-static
+
+ # musl does not have _STAT_VER, it's really not used for
+ # anything, so define it as zero (just like uclibc does)
+ [ "${CHOST#*musl}" != "$CHOST" ] && CFLAGS="-D_STAT_VER=0 $CFLAGS"
+
+ CONFIG_SHELL=/bin/sh \
+ ./configure --prefix=/usr \
+ --build=${CBUILD} \
+ --host=${CHOST} \
+ --disable-static
make || return 1
}
@@ -38,3 +47,11 @@ md5sums="706171d8d520b1ca1576ac73f2ceb4f3 fakeroot_1.18.4.orig.tar.bz2
bdbf1db14f2cfdff0f5b4c35da78b9fe busybox-getopt.patch
50a899380cfd5eae8ce3aaf878fb17b2 fakeroot-stdint.patch
7a54ab51fdb90bc44e366e0a66811bfe fakeroot-uclibc.patch"
+sha256sums="0a359efa3e9496c33234b3e9c89306a09bb4da9d33de43c261f1d8447e6ebea2 fakeroot_1.18.4.orig.tar.bz2
+e915ce6cf414da590d39c735e1e522725717f43bfe6da77bd62cd1be365a06ec busybox-getopt.patch
+8739c0b79c3f2b0e46cd0dffa8b73d946efbe994f61f69f7d1115c2dcec22df1 fakeroot-stdint.patch
+e325ad9aad310caa71002adea220795f706c621c5794093f16c0f319b3d58977 fakeroot-uclibc.patch"
+sha512sums="497292fe21d18a37eadd657fbe01db8902f4b8d87d63605928efd59789f4c14737997b9f0abc4d794dbef78066b952064bdb2dd9f0910ec75349d7dd313cd058 fakeroot_1.18.4.orig.tar.bz2
+3a3cfcddbfe6685111d2a9dd93ebe5816bacab664aa19004cc39e18c00b5ef8045cb153755f66cabb204f17e2495ce38e2fb37fdc8da01cc69ec62e4694e3001 busybox-getopt.patch
+ed7a58b0d201139545420f9e5429f503c00e00f36dea84473e77ea99b23bb8d421da1a8a8ce98ff90e72e378dff4cb9ea3c1a863a969899a5f50dfac3b9c5fac fakeroot-stdint.patch
+783ceaf00c6c1c190327dbc3f67761488aaeb23e40b3a249bcaf301f99334721a864f8a730abfb0e17467bad24f5db9127d83379dea3ef24b6f708ff7dfb3f98 fakeroot-uclibc.patch"