summaryrefslogtreecommitdiffstats
path: root/main/fakeroot
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-28 09:09:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-28 09:09:37 +0000
commitb1929ab2b48d9c3c96792cca24a60606ab276bbb (patch)
treea2f7d9a09eb36b1b2cfa1117ef9435bcc376cc91 /main/fakeroot
parentffcc74ea00d0cad9343905005e6c3ec9f19fc861 (diff)
downloadaports-b1929ab2b48d9c3c96792cca24a60606ab276bbb.tar.bz2
aports-b1929ab2b48d9c3c96792cca24a60606ab276bbb.tar.xz
main/fakeroot: upgrade to 1.18.1
Diffstat (limited to 'main/fakeroot')
-rw-r--r--main/fakeroot/APKBUILD14
-rw-r--r--main/fakeroot/busybox-compat.patch23
-rw-r--r--main/fakeroot/busybox-getopt.patch13
3 files changed, 22 insertions, 28 deletions
diff --git a/main/fakeroot/APKBUILD b/main/fakeroot/APKBUILD
index 6ab928871..547bc5c91 100644
--- a/main/fakeroot/APKBUILD
+++ b/main/fakeroot/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fakeroot
-pkgver=1.17
+pkgver=1.18.1
pkgrel=0
pkgdesc="Gives a fake root environment, useful for building packages as a non-privileged user"
arch="all"
@@ -9,11 +9,15 @@ url="http://packages.debian.org/fakeroot"
depends=
subpackages="$pkgname-doc"
source="http://ftp.debian.org/debian/pool/main/f/$pkgname/${pkgname}_${pkgver}.orig.tar.bz2
- busybox-compat.patch"
+ busybox-getopt.patch"
prepare() {
cd $startdir/src/$pkgname-$pkgver
- patch -p1 < ../busybox-compat.patch
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -28,5 +32,5 @@ package() {
rm "$pkgdir"/usr/lib/*.la
}
-md5sums="1adc603cc18eedee11d9889798c863db fakeroot_1.17.orig.tar.bz2
-ea7b7e3065090d72804cdf4719dd5832 busybox-compat.patch"
+md5sums="8eedda3dcb71b6ab6f62297b82ae5ac6 fakeroot_1.18.1.orig.tar.bz2
+bdbf1db14f2cfdff0f5b4c35da78b9fe busybox-getopt.patch"
diff --git a/main/fakeroot/busybox-compat.patch b/main/fakeroot/busybox-compat.patch
deleted file mode 100644
index 1d07d0d31..000000000
--- a/main/fakeroot/busybox-compat.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- fakeroot-1.10.1.orig/scripts/fakeroot.in Wed Nov 5 19:48:00 2008
-+++ fakeroot-1.10.1/scripts/fakeroot.in Wed Nov 5 19:49:12 2008
-@@ -28,7 +28,7 @@
-
- libfound=no
-
--GETOPTEST=`getopt --version`
-+GETOPTEST=`getopt --version 2>/dev/null`
- case $GETOPTEST in
- getopt*) # GNU getopt
- TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`
-@@ -133,9 +133,9 @@
- PID=`echo $KEY_PID|cut -d: -f2`
-
- if [ "$WAITINTRAP" -eq 0 ]; then
-- trap "kill -s @signal@ $PID" EXIT INT
-+ trap "kill -@signal@ $PID" EXIT INT
- else
-- trap 'FAKEROOTKEY=$FAKEROOTKEY LD_LIBRARY_PATH="$PATHS" LD_PRELOAD="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -s @signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
-+ trap 'FAKEROOTKEY=$FAKEROOTKEY LD_LIBRARY_PATH="$PATHS" LD_PRELOAD="$LIB" /bin/ls -l / >/dev/null 2>&1; while kill -@signal@ $PID 2>/dev/null; do sleep 0.1; done' EXIT INT
- fi
-
- if test -z "$FAKEROOTKEY" || test -z "$PID"; then
diff --git a/main/fakeroot/busybox-getopt.patch b/main/fakeroot/busybox-getopt.patch
new file mode 100644
index 000000000..94029bf24
--- /dev/null
+++ b/main/fakeroot/busybox-getopt.patch
@@ -0,0 +1,13 @@
+diff --git a/scripts/fakeroot.in b/scripts/fakeroot.in
+index 324a9dc..8d4235d 100755
+--- a/scripts/fakeroot.in
++++ b/scripts/fakeroot.in
+@@ -43,7 +43,7 @@ export FAKED_MODE
+
+ libfound=no
+
+-GETOPTEST=`getopt --version`
++GETOPTEST=`getopt --version 2>/dev/null`
+ case $GETOPTEST in
+ getopt*) # GNU getopt
+ FAKE_TEMP=`getopt -l lib: -l faked: -l unknown-is-real -l fd-base: -l version -l help -- +l:f:i:s:ub:vh "$@"`