summaryrefslogtreecommitdiffstats
path: root/main/ffmpeg1
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-10-28 11:01:09 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-10-28 11:01:09 +0000
commit6394d7d8c3f4bd6c704943462391ee313bf200b7 (patch)
tree8d9ae320ae7f2e57147a65cf921dac57034d6b72 /main/ffmpeg1
parent5f23cebed477095dfe3c76034f155f7b1974bd7b (diff)
downloadaports-6394d7d8c3f4bd6c704943462391ee313bf200b7.tar.bz2
aports-6394d7d8c3f4bd6c704943462391ee313bf200b7.tar.xz
main/ffmpeg1: fix arm build
like ffmpeg2, disable arm assembly as it has textrels.
Diffstat (limited to 'main/ffmpeg1')
-rw-r--r--main/ffmpeg1/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/ffmpeg1/APKBUILD b/main/ffmpeg1/APKBUILD
index 27793f3ef..0231fae99 100644
--- a/main/ffmpeg1/APKBUILD
+++ b/main/ffmpeg1/APKBUILD
@@ -31,7 +31,11 @@ build() {
local _dbg="--disable-debug"
local _asm=""
[ -n "$DEBUG" ] && _dbg="--enable-debug"
- [ "$CARCH" = "x86" ] && _asm="--disable-asm"
+
+ case "$CARCH" in
+ x86 | arm*) _asm="--disable-asm" ;;
+ esac
+
cd "$_builddir"
./configure \
--prefix=/usr \