summaryrefslogtreecommitdiffstats
path: root/main/flite
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-02 11:05:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-02 11:05:42 +0000
commit1e9d75e5a8a64738d5c0dc5fcc9d3c499b9b4968 (patch)
tree56ae386c776d4757d47113e9f9cde211cea99772 /main/flite
parentbc5b6eeaa67b6879034c863720e865ff76c2290d (diff)
downloadaports-1e9d75e5a8a64738d5c0dc5fcc9d3c499b9b4968.tar.bz2
aports-1e9d75e5a8a64738d5c0dc5fcc9d3c499b9b4968.tar.xz
main/flite,gsm: moved from testing
needed by sems
Diffstat (limited to 'main/flite')
-rw-r--r--main/flite/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/main/flite/APKBUILD b/main/flite/APKBUILD
new file mode 100644
index 000000000..dad470302
--- /dev/null
+++ b/main/flite/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=flite
+pkgver=1.4
+pkgrel=1
+pkgdesc="Small, fast speech synthesis engine (text-to-speech)"
+url="http://www.speech.cs.cmu.edu/flite/"
+arch="all"
+license="MIT"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://www.speech.cs.cmu.edu/flite/packed/flite-1.4/flite-$pkgver-release.tar.bz2"
+
+_builddir="$srcdir"/flite-$pkgver-release
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ CFLAGS="$CFLAGS -fPIC" ./configure --prefix=/usr \
+ --enable-shared \
+ --localstatedir=/var \
+ || return 1
+ # work around parallel build issue
+ make -C include
+ make -C src
+ make -C lang
+ make -C tools
+ make -j1 || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install INSTALLBINDIR="$pkgdir"/usr/bin \
+ INSTALLLIBDIR="$pkgdir"/usr/lib \
+ INSTALLINCDIR="$pkgdir"/usr/include/flite \
+ || return 1
+}
+
+md5sums="b7c3523b3bbc6f29ce61e6650cd9a428 flite-1.4-release.tar.bz2"