summaryrefslogtreecommitdiffstats
path: root/main/freeswitch/APKBUILD
diff options
context:
space:
mode:
authorCameron Banta <cbanta@gmail.com>2011-05-28 01:56:41 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-06-01 10:56:13 +0000
commit9e0dd43b37174f24d8f1072760161b16a359d563 (patch)
treee0c7190b11c7d74bc1df7c3173527b7504a790ec /main/freeswitch/APKBUILD
parent6117e45c4fd17bcb54592ccda0e223697e71005a (diff)
downloadaports-9e0dd43b37174f24d8f1072760161b16a359d563.tar.bz2
aports-9e0dd43b37174f24d8f1072760161b16a359d563.tar.xz
main/freeswitch: update to latest version
Diffstat (limited to 'main/freeswitch/APKBUILD')
-rw-r--r--main/freeswitch/APKBUILD37
1 files changed, 26 insertions, 11 deletions
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index b07f3c97c..9225b053e 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -1,19 +1,21 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=freeswitch
-pkgver=1.0.7_p20110323
+pkgver=1.0.7_p20110527
_ver=${pkgver%_p*}
_snapshot=${pkgver#*_p}
-pkgrel=1
+pkgrel=0
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
license="GPL"
depends=""
makedepends="curl-dev unixodbc-dev zlib-dev openssl-dev ncurses-dev
- autoconf automake libtool libpri-dev bash"
+ autoconf automake libtool libpri-dev bash net-snmp-dev postgresql-dev
+ libiconv-dev subversion flac-dev libogg-dev libvorbis-dev
+ jpeg-dev"
install="$pkgname.pre-install $pkgname.post-install $pkgname.pre-upgrade"
-subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf"
+subpackages="$pkgname-dev $pkgname-flite $pkgname-sample-config:conf $pkgname-freetdm"
source="saveas-http://latest.freeswitch.org/freeswitch-$_ver.tar.gz/freeswitch-$pkgver.tar.gz
freeswitch-mod_shout-textrels.patch
modules.conf
@@ -40,7 +42,7 @@ build() {
# by specifying it here we save our selves from some CPU cycles
export lt_cv_sys_max_cmd_len=8192
- ./rebootstrap.sh
+ ./bootstrap.sh
cp -f "$srcdir/modules.conf" modules.conf || return 1
@@ -93,15 +95,28 @@ _mv_mod() {
flite() {
pkgdesc="Freeswitch Text To Speech Module"
- depends="freeswitch"
install=
- _mv_mod mod_flite mod_say_de mod_say_en mod_say_es mod_say_fr \
- mod_say_it mod_say_nl mod_say_zh
+ _mv_mod mod_flite
+##
+## The mod_say_xx modules can be used with out flite (for numbers, etc using
+## sound files). So they shouldn't be in the flite package -cB
+##
+# _mv_mod mod_say_de mod_say_en mod_say_es mod_say_fr \
+# mod_say_it mod_say_nl mod_say_zh mod_say_hu mod_say_ru \
+# mod_say_th mod_say_he
+}
+
+freetdm() {
+ pkgdesc="Freeswitch FreeTDM Module"
+ install=
+ _mv_mod mod_freetdm ftmod_analog ftmod_analog_em ftmod_libpri \
+ ftmod_skel ftmod_zt
+ mv "$pkgdir"/usr/lib/libfreetdm.so* "$subpkgdir"/usr/lib/
}
conf() {
pkgdesc="Freeswitch sample configureation"
- depends="freeswitch"
+ arch="noarch"
install=
mkdir -p "$subpkgdir"/etc/freeswitch
# move all configs except freeswitch.xml
@@ -112,8 +127,8 @@ conf() {
mkdir -p "$pkgdir"/etc/freeswitch/scripts
}
-md5sums="ecca23d810c8ec1853c87c7fdc603bc5 freeswitch-1.0.7_p20110323.tar.gz
+md5sums="da85600034285da3d96c864201c4e08b freeswitch-1.0.7_p20110527.tar.gz
11883affe0839a8e15fe680aeb11b86e freeswitch-mod_shout-textrels.patch
-8363688bc8dd21ac1da0f840d770504b modules.conf
+691fa3aca967203848bbb2a617545265 modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
aa358c9ca0d8b93fabb6a36a5ed4c469 freeswitch.initd"