summaryrefslogtreecommitdiffstats
path: root/main/gc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-09 20:14:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-09 20:15:39 +0000
commita88edfcdfad6c7f2025bc0775f8f3d01ff6c24cc (patch)
treed69bcc45c57dc28cfa27b19f0daea4534a0b5719 /main/gc
parent8d7276ceeb6636a733d64c6efe005f1c9102092c (diff)
downloadaports-a88edfcdfad6c7f2025bc0775f8f3d01ff6c24cc.tar.bz2
aports-a88edfcdfad6c7f2025bc0775f8f3d01ff6c24cc.tar.xz
main/gc: disable getcontext
Diffstat (limited to 'main/gc')
-rw-r--r--main/gc/APKBUILD14
-rw-r--r--main/gc/getcontext.patch10
2 files changed, 21 insertions, 3 deletions
diff --git a/main/gc/APKBUILD b/main/gc/APKBUILD
index 7a2a6df24..e8db51952 100644
--- a/main/gc/APKBUILD
+++ b/main/gc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gc
pkgver=7.2
-pkgrel=0
+pkgrel=1
pkgdesc="A garbage collector for C and C++"
url="http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
arch="all"
@@ -9,10 +9,17 @@ license="GPL"
depends=
makedepends=
subpackages="$pkgname-dev $pkgname-doc libgc++:libgccpp"
-source="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-$pkgver.tar.gz"
+source="http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-$pkgver.tar.gz
+ getcontext.patch
+ "
prepare() {
cd "$srcdir"/$pkgname-$pkgver
+ for i in $source; do
+ case $i in
+ *.patch) msg $; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -34,4 +41,5 @@ libgccpp() {
mv "$pkgdir"/usr/lib/libgccpp.* "$subpkgdir"/usr/lib/
}
-md5sums="d17aecedef3d73e75387fb63558fa4eb gc-7.2.tar.gz"
+md5sums="d17aecedef3d73e75387fb63558fa4eb gc-7.2.tar.gz
+4f77dfa0098f982ce42dc1580d31bf47 getcontext.patch"
diff --git a/main/gc/getcontext.patch b/main/gc/getcontext.patch
new file mode 100644
index 000000000..df3e45a05
--- /dev/null
+++ b/main/gc/getcontext.patch
@@ -0,0 +1,10 @@
+--- ./include/private/gcconfig.h.orig
++++ ./include/private/gcconfig.h
+@@ -2483,6 +2483,7 @@
+ #if ((defined(UNIX_LIKE) && (defined(DARWIN) || defined(HURD) \
+ || defined(OPENBSD) || defined(ARM32) \
+ || defined(MIPS) || defined(AVR32))) \
++ || defined(__UCLIBC__) \
+ || (defined(LINUX) && (defined(SPARC) || defined(M68K))) \
+ || (defined(RTEMS) && defined(I386))) && !defined(NO_GETCONTEXT)
+ # define NO_GETCONTEXT