summaryrefslogtreecommitdiffstats
path: root/main/gdb
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-01-14 07:33:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-01-14 07:33:42 +0000
commit8d064b0b0311341e383dead00a400ad92b2f3044 (patch)
tree6244ab66fa894dfcc27e3d18ae94a52b1d1c20bc /main/gdb
parentd8a8acd1151a2017a999d4d8bcacc0430c4fb07e (diff)
downloadaports-8d064b0b0311341e383dead00a400ad92b2f3044.tar.bz2
aports-8d064b0b0311341e383dead00a400ad92b2f3044.tar.xz
main/gdb: build fix for musl x86_64
Diffstat (limited to 'main/gdb')
-rw-r--r--main/gdb/APKBUILD14
-rw-r--r--main/gdb/gdb-amd64-debugreg.patch64
2 files changed, 73 insertions, 5 deletions
diff --git a/main/gdb/APKBUILD b/main/gdb/APKBUILD
index dd40ff1a2..25a66708f 100644
--- a/main/gdb/APKBUILD
+++ b/main/gdb/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdb
pkgver=7.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Debugger"
url="http://sources.redhat.com/gdb/"
arch="all"
@@ -16,6 +16,7 @@ source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.bz2
gdb-linux_nat.patch
gdb-linux_osdata.patch
gdb-linux_threaddb.patch
+ gdb-amd64-debugreg.patch
"
# patches were found here:
# http://distfiles.gentoo.org/distfiles/gdb-7.4-patches-1.tar.xz
@@ -60,7 +61,7 @@ package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
rm -f "$pkgdir"/usr/share/info/dir
- # those are provided by binutils
+ # those are provided by binutils
rm -rf "$pkgdir"/usr/include
rm -rf "$pkgdir"/usr/lib
}
@@ -70,16 +71,19 @@ md5sums="496399e96654fc0f899a5c964bc1f0f8 gdb-7.6.2.tar.bz2
a679796124dc56798cdebffa524f661c cpuid-pic.patch
fa690484f7cdd2d552216d515653b97f gdb-linux_nat.patch
58e5c62bd1104f61d1f01809aab55abb gdb-linux_osdata.patch
-70777c7a82f3cbab0a70a9088feea4ac gdb-linux_threaddb.patch"
+70777c7a82f3cbab0a70a9088feea4ac gdb-linux_threaddb.patch
+c66ba0aa72baea5bea429461607c5664 gdb-amd64-debugreg.patch"
sha256sums="2f6a0e2ce1c66c9dedeb7f58a8d1298ad602ddcdaf15d23104e1f7832b96d0e8 gdb-7.6.2.tar.bz2
390a88feac5f1d3980458057e1903a3fa104edb32daa6bb76396af1cb91cefc2 05_all_readline-headers.patch
d22ce97b01c3bb25cc17831c60b984eebe2c1fe573b04a0d87e535794294e399 cpuid-pic.patch
15eef2bf2679353de30e31f6b60b1045e453519f4f2e9fc84472b68a0c35d83d gdb-linux_nat.patch
9d92d4e760d604771a835181b35930b960abdaa9aaee699544484602cc09dfb5 gdb-linux_osdata.patch
-0ec1c6c3fa09ecce7872bf1ba8a40b06238f62b4587b4d15fe29229f75cbc997 gdb-linux_threaddb.patch"
+0ec1c6c3fa09ecce7872bf1ba8a40b06238f62b4587b4d15fe29229f75cbc997 gdb-linux_threaddb.patch
+ab242331458c8a0c1bb99e8fe0d53ff5dd5d443cbe2ee67668b2bdbabb5c5019 gdb-amd64-debugreg.patch"
sha512sums="e72e9c2abb58cc08c38841380270fe783f26baf62798171d21cf0843e6c9a81d285f424dc6229ea7b1c6c957d999c8aa75c2bd15076817abb9caab28c4eb7666 gdb-7.6.2.tar.bz2
dfb7f7272305779599d3da51ce1158628473534a96f2721d7060930c94800a4efc061321bc5a9e455c72f670cfb77f0eb01cb696da55a4accf96f555377f551f 05_all_readline-headers.patch
10551a28767b270ff5107fde595ad8877f3f2d684edccc85c18d08e3a9a2c4afe48da804adf9f8e716b666817906b22565a614d22fbc91e4ee650e1ecdb8fb0e cpuid-pic.patch
c61cdf6a0b518125d977a26f8929948a47205a396e011730719b49d1395d4889a03e216108c00b1ffe28fc4ac9a820e1cdf55b69fa246d2b2f890b8da46d8508 gdb-linux_nat.patch
209de5ce0f2c01e313fc39f97576e67b8a98a991d45d302906e4b85f2e21e2948e76d530f2554964042e53d827af0414aee64a30bfa176e77815658fbc11ea0b gdb-linux_osdata.patch
-af29422ef3b5bf2d95868532a1054a50141dd072c061003e6b86ac922e20d2e16baabb9eeb92c06734ae5ee86cdd40f1ef8e807fe258b56ad6b3513ad7915523 gdb-linux_threaddb.patch"
+af29422ef3b5bf2d95868532a1054a50141dd072c061003e6b86ac922e20d2e16baabb9eeb92c06734ae5ee86cdd40f1ef8e807fe258b56ad6b3513ad7915523 gdb-linux_threaddb.patch
+6e88171db53bb9e62cbfb5e75a2df17ebd577c85c04965bc6bf93db99ccc51663d0c14edd77bf59cf88bdab73cda37e0d15600770872451d45ffe11bbd591d2b gdb-amd64-debugreg.patch"
diff --git a/main/gdb/gdb-amd64-debugreg.patch b/main/gdb/gdb-amd64-debugreg.patch
new file mode 100644
index 000000000..e7d380ee1
--- /dev/null
+++ b/main/gdb/gdb-amd64-debugreg.patch
@@ -0,0 +1,64 @@
+diff -u -r -N gdb-7.3.1-org//gdb/amd64-linux-nat.c gdb-7.3.1-patched//gdb/amd64-linux-nat.c
+--- gdb-7.3.1-org//gdb/amd64-linux-nat.c 1970-01-01 00:00:00.000000000 +0000
++++ gdb-7.3.1-patched//gdb/amd64-linux-nat.c 2011-09-22 22:20:23.438841813 +0000
+@@ -32,7 +32,7 @@
+ #include "elf/common.h"
+ #include <sys/uio.h>
+ #include <sys/ptrace.h>
+-#include <sys/debugreg.h>
++#include "debugreg.h"
+ #include <sys/syscall.h>
+ #include <sys/procfs.h>
+ #include <asm/prctl.h>
+diff -u -r -N gdb-7.3.1-org//gdb/debugreg.h gdb-7.3.1-patched//gdb/debugreg.h
+--- gdb-7.3.1-org//gdb/debugreg.h 1970-01-01 00:00:00.000000000 +0000
++++ gdb-7.3.1-patched//gdb/debugreg.h 2011-09-22 22:20:01.381841813 +0000
+@@ -0,0 +1,48 @@
++#ifndef SYS_DEBUGREG_H
++#define SYS_DEBUGREG_H
++
++#include <stdint.h>
++
++#define DR_FIRSTADDR 0
++#define DR_LASTADDR 3
++
++#define DR_STATUS 6
++#define DR_CONTROL 7
++
++#define DR_TRAP0 (0x1)
++#define DR_TRAP1 (0x2)
++#define DR_TRAP2 (0x4)
++#define DR_TRAP3 (0x8)
++
++#define DR_STEP (0x4000)
++#define DR_SWITCH (0x8000)
++
++#define DR_CONTROL_SHIFT 16
++#define DR_CONTROL_SIZE 4
++
++#define DR_RW_EXECUTE (0x0)
++#define DR_RW_WRITE (0x1)
++#define DR_RW_READ (0x3)
++
++#define DR_LEN_1 (0x0)
++#define DR_LEN_2 (0x4)
++#define DR_LEN_4 (0xC)
++#define DR_LEN_8 (0x8)
++
++#define DR_LOCAL_ENABLE_SHIFT 0
++#define DR_GLOBAL_ENABLE_SHIFT 1
++#define DR_ENABLE_SIZE 2
++
++#define DR_LOCAL_ENABLE_MASK (0x55)
++#define DR_GLOBAL_ENABLE_MASK (0xAA)
++
++
++#if SIZE_MAX > 4294967295
++# define DR_CONTROL_RESERVED (0xFFFFFFFF0000FC00UL)
++#else
++# define DR_CONTROL_RESERVED (0x00FC00U)
++#endif
++#define DR_LOCAL_SLOWDOWN (0x100)
++#define DR_GLOBAL_SLOWDOWN (0x200)
++
++#endif