summaryrefslogtreecommitdiffstats
path: root/main/gdnsd
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2012-05-09 16:06:22 +0300
committerTimo Teräs <timo.teras@iki.fi>2012-05-09 16:07:06 +0300
commit1952e27109df343f47ca5f7c5e4052f9394918e0 (patch)
treec5660e459b4315a60a6064472ad898ce830ae32a /main/gdnsd
parent30b76125f85c4ed7cf83ea84c96517c6395eb7bc (diff)
downloadaports-1952e27109df343f47ca5f7c5e4052f9394918e0.tar.bz2
aports-1952e27109df343f47ca5f7c5e4052f9394918e0.tar.xz
main/gdnsd: upgrade to 1.6.5 and update init.d
Diffstat (limited to 'main/gdnsd')
-rw-r--r--main/gdnsd/APKBUILD8
-rwxr-xr-xmain/gdnsd/gdnsd.initd38
2 files changed, 36 insertions, 10 deletions
diff --git a/main/gdnsd/APKBUILD b/main/gdnsd/APKBUILD
index 6da9d6caa..b7646bfcf 100644
--- a/main/gdnsd/APKBUILD
+++ b/main/gdnsd/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gdnsd
-pkgver=1.6.2
-pkgrel=2
+pkgver=1.6.5
+pkgrel=0
pkgdesc="Geographic Authoritative DNS server"
url="http://code.google.com/p/gdnsd/"
arch="all"
@@ -45,5 +45,5 @@ package() {
"$pkgdir"/usr/lib/gdnsd/*.la
}
-md5sums="082f874d24cdc7073950ed6294f8d39b gdnsd-1.6.2.tar.xz
-dad20779adfb4b85b57b45c7c903a636 gdnsd.initd"
+md5sums="8fb68b6e3d9d118b3ef0d3ad248a2219 gdnsd-1.6.5.tar.xz
+00f2838e0908effaaa2f6e6a1699f25b gdnsd.initd"
diff --git a/main/gdnsd/gdnsd.initd b/main/gdnsd/gdnsd.initd
index e11a73d1d..2dbb56897 100755
--- a/main/gdnsd/gdnsd.initd
+++ b/main/gdnsd/gdnsd.initd
@@ -1,18 +1,44 @@
#!/sbin/runscript
+name="gdnsd daemon"
+extra_commands="configtest"
+extra_started_commands="reload"
+description_configtest="Run syntax tests for configuration files only."
+description_reload="Fast reload: check config, load files, kill old server, start new server (in this order)."
+
+if [ -z "${GDNSD_CONFFILE}" ]; then
+ if [ "${SVCNAME}" = "gdnsd" ]; then
+ GDNSD_CONFFILE=/etc/gdnsd/config
+ else
+ GDNSD_CONFFILE=/etc/gdnsd/${SVCNAME}.config
+ fi
+fi
+
depend() {
need net
+ use logger
after firewall
+ provide auth-dns
}
-start() {
- ebegin "Starting dnsd"
- start-stop-daemon --start --exec /usr/sbin/dnsd -- -d $DNSD_OPTS
+act() {
+ ebegin "$1 ${SVCNAME}"
+ /usr/sbin/gdnsd -c ${GDNSD_CONFFILE} ${GDNSD_OPTS} $2
eend $?
}
+start() {
+ act "Starting" start
+}
+
stop () {
- ebegin "Stopping dnsd"
- start-stop-daemon --stop --exec /usr/sbin/dnsd
- eend $?
+ act "Stopping" stop
+}
+
+reload() {
+ act "Reloading" restart
+}
+
+configtest() {
+ act "Checking configuration" checkconf
}