summaryrefslogtreecommitdiffstats
path: root/main/gnome-panel
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-23 11:17:13 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-23 11:21:30 +0000
commit6c547fbd00feda806c22fcdd037908d81d2553ef (patch)
tree9dcdb092fb136798bf0f7e237165b90ad9e41249 /main/gnome-panel
parent7229d1b28ba2bbe7d2fd3bbc5b888df6df7fa82e (diff)
downloadaports-6c547fbd00feda806c22fcdd037908d81d2553ef.tar.bz2
aports-6c547fbd00feda806c22fcdd037908d81d2553ef.tar.xz
main/gnome-panel: fix linking issues and split out -lang
Diffstat (limited to 'main/gnome-panel')
-rw-r--r--main/gnome-panel/APKBUILD12
-rw-r--r--main/gnome-panel/as-needed.patch24
-rw-r--r--main/gnome-panel/libm-underlinking.patch11
3 files changed, 43 insertions, 4 deletions
diff --git a/main/gnome-panel/APKBUILD b/main/gnome-panel/APKBUILD
index 92db6be88..99eda6723 100644
--- a/main/gnome-panel/APKBUILD
+++ b/main/gnome-panel/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=gnome-panel
pkgver=2.32.1
-pkgrel=9
+pkgrel=10
pkgdesc="GNOME Panel"
url="http://projects.gnome.org/gnome-panel"
arch="all"
@@ -20,9 +20,11 @@ depends_dev="gtk+-dev
libgweather-dev"
makedepends="$depends_dev intltool gobject-introspection-dev"
install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
-subpackages="$pkgname-dev"
+subpackages="$pkgname-dev $pkgname-lang"
replaces_dev="$pkgname"
-source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2"
+source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ as-needed.patch
+ libm-underlinking.patch"
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -51,4 +53,6 @@ package() {
rm "$pkgdir"/usr/lib/*.la
}
-md5sums="a228035e1f7026abf296b797f1f7d2f9 gnome-panel-2.32.1.tar.bz2"
+md5sums="a228035e1f7026abf296b797f1f7d2f9 gnome-panel-2.32.1.tar.bz2
+42a7f2693e5f99ce3440bd53ebccbae0 as-needed.patch
+292372a7f264bb63ca9eb3c69a664ee1 libm-underlinking.patch"
diff --git a/main/gnome-panel/as-needed.patch b/main/gnome-panel/as-needed.patch
new file mode 100644
index 000000000..87e95e010
--- /dev/null
+++ b/main/gnome-panel/as-needed.patch
@@ -0,0 +1,24 @@
+--- ./applets/notification_area/Makefile.in.orig
++++ ./applets/notification_area/Makefile.in
+@@ -403,17 +403,17 @@
+
+ NOTIFICATION_AREA_SOURCES = main.c
+ NOTIFICATION_AREA_LDADD = \
++ libtray.la \
+ ../../libpanel-applet/libpanel-applet-3.la \
+ $(X_LIBS) \
+ $(NOTIFICATION_AREA_LIBS) \
+- $(LIBPANEL_APPLET_LIBS) \
+- libtray.la
++ $(LIBPANEL_APPLET_LIBS)
+
+ testtray_SOURCES = testtray.c
+ testtray_LDADD = \
++ libtray.la \
+ $(X_LIBS) \
+- $(NOTIFICATION_AREA_LIBS) \
+- libtray.la
++ $(NOTIFICATION_AREA_LIBS)
+
+ @NOTIFICATION_AREA_INPROCESS_FALSE@APPLET_IN_PROCESS = false
+ @NOTIFICATION_AREA_INPROCESS_TRUE@APPLET_IN_PROCESS = true
diff --git a/main/gnome-panel/libm-underlinking.patch b/main/gnome-panel/libm-underlinking.patch
new file mode 100644
index 000000000..9d56f0648
--- /dev/null
+++ b/main/gnome-panel/libm-underlinking.patch
@@ -0,0 +1,11 @@
+--- ./gnome-panel/Makefile.in.orig
++++ ./gnome-panel/Makefile.in
+@@ -582,7 +582,7 @@
+ $(top_builddir)/gnome-panel/libpanel-util/libpanel-util.la \
+ $(PANEL_LIBS) \
+ $(XRANDR_LIBS) \
+- $(X_LIBS)
++ $(X_LIBS) -lm
+
+ gnome_panel_LDFLAGS = -export-dynamic
+ gnome_desktop_item_edit_SOURCES = \