summaryrefslogtreecommitdiffstats
path: root/main/gnome-power-manager
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-11-16 19:20:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-11-16 19:20:11 +0000
commit339341856d8fbd1d4faa8fe52cf18d4081b79a70 (patch)
tree4b405212ed11d6b9f9151f8d8d8a0b40b7cc9a3d /main/gnome-power-manager
parent8db3c2f7bbd8565b51f6b7e89fb263502115fef7 (diff)
downloadaports-339341856d8fbd1d4faa8fe52cf18d4081b79a70.tar.bz2
aports-339341856d8fbd1d4faa8fe52cf18d4081b79a70.tar.xz
main/gnome-power-manager: rebuild against libnotify-0.7
Diffstat (limited to 'main/gnome-power-manager')
-rw-r--r--main/gnome-power-manager/APKBUILD11
-rw-r--r--main/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch30
2 files changed, 37 insertions, 4 deletions
diff --git a/main/gnome-power-manager/APKBUILD b/main/gnome-power-manager/APKBUILD
index 090587235..5fbe12c4d 100644
--- a/main/gnome-power-manager/APKBUILD
+++ b/main/gnome-power-manager/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=gnome-power-manager
pkgver=2.32.0
-pkgrel=0
+pkgrel=1
pkgdesc="GNOME power manager"
url="http://www.gnome.org"
arch="all"
@@ -31,9 +31,11 @@ depends_dev="gtk+-dev
libxrandr-dev"
makedepends="$depends_dev intltool gobject-introspection-dev"
install="$pkgname.post-install $pkgname.pre-deinstall $pkgname.post-upgrade"
-subpackages=
+subpackages="$pkgname-lang"
source="ftp://ftp.gnome.org/pub/GNOME/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
- execinfo.patch"
+ execinfo.patch
+ gnome-power-manager-2.32.0-libnotify-0.7.patch
+ "
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -63,4 +65,5 @@ package() {
}
md5sums="9a08e85dce3ffb90775f15e3bda4adda gnome-power-manager-2.32.0.tar.bz2
-f7500645244232328869d303cc6860aa execinfo.patch"
+f7500645244232328869d303cc6860aa execinfo.patch
+d716958711516e02b47243abed7af86d gnome-power-manager-2.32.0-libnotify-0.7.patch"
diff --git a/main/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch b/main/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch
new file mode 100644
index 000000000..022d2c5fe
--- /dev/null
+++ b/main/gnome-power-manager/gnome-power-manager-2.32.0-libnotify-0.7.patch
@@ -0,0 +1,30 @@
+--- ./src/gpm-manager.c
++++ ./src/gpm-manager.c
+@@ -43,6 +43,10 @@
+ #include <libupower-glib/upower.h>
+ #include <libnotify/notify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include "egg-debug.h"
+ #include "egg-console-kit.h"
+
+@@ -480,12 +484,16 @@
+ /* close any existing notification of this class */
+ gpm_manager_notify_close (manager, *notification_class);
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ notification = notify_notification_new (title, message, icon);
++#else
+ /* if the status icon is hidden, don't point at it */
+ if (manager->priv->status_icon != NULL &&
+ gtk_status_icon_is_embedded (manager->priv->status_icon))
+ notification = notify_notification_new_with_status_icon (title, message, icon, manager->priv->status_icon);
+ else
+ notification = notify_notification_new (title, message, icon, NULL);
++#endif
+ notify_notification_set_timeout (notification, timeout);
+ notify_notification_set_urgency (notification, urgency);
+ g_signal_connect (notification, "closed", G_CALLBACK (gpm_manager_notification_closed_cb), notification_class);