summaryrefslogtreecommitdiffstats
path: root/main/graphviz
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-18 08:54:26 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-18 08:54:26 +0000
commit1db45dc64fa032504d5540e3c84f3319070955a0 (patch)
tree1eb7ff822802c001e65047b89f40d2ac0066ef2c /main/graphviz
parentc4af99e94fed5847c7a39b7c5c22578f2715229c (diff)
downloadaports-1db45dc64fa032504d5540e3c84f3319070955a0.tar.bz2
aports-1db45dc64fa032504d5540e3c84f3319070955a0.tar.xz
main/graphviz: fix musl build
Diffstat (limited to 'main/graphviz')
-rw-r--r--main/graphviz/APKBUILD15
-rw-r--r--main/graphviz/musl-posix-grep.patch22
2 files changed, 32 insertions, 5 deletions
diff --git a/main/graphviz/APKBUILD b/main/graphviz/APKBUILD
index c6a123ed3..461787b3b 100644
--- a/main/graphviz/APKBUILD
+++ b/main/graphviz/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=graphviz
pkgver=2.34.0
-pkgrel=1
+pkgrel=2
pkgdesc="Graph Visualization Tools"
url="http://www.graphviz.org/"
arch="all"
@@ -16,7 +16,9 @@ install=""
subpackages="$pkgname-dev $pkgname-doc py-$pkgname:py lua-$pkgname:_lua
$pkgname-gtk $pkgname-graphs"
source="http://www.graphviz.org/pub/graphviz/stable/SOURCES/graphviz-$pkgver.tar.gz
- 0001-clone-nameclash.patch"
+ 0001-clone-nameclash.patch
+ musl-posix-grep.patch
+ "
_builddir="$srcdir"/graphviz-$pkgver
prepare() {
@@ -107,8 +109,11 @@ graphs() {
"$subpkgdir"/usr/share/graphviz/
}
md5sums="a8a54f8abac5bcdafd9a568e85a086d6 graphviz-2.34.0.tar.gz
-bce8a9ae4c3a8c52c1bcf0e03d5ce364 0001-clone-nameclash.patch"
+bce8a9ae4c3a8c52c1bcf0e03d5ce364 0001-clone-nameclash.patch
+f2e8e751d8b26dd659b51940f7210b8a musl-posix-grep.patch"
sha256sums="d94abca5745aa4c5808ab56cd3d0ec9ed14fb76a5a88d39e1f234fa84d22d764 graphviz-2.34.0.tar.gz
-2b6c8186bf2799658494428d68597f63b91799f37809cbe59d8adcab60c27363 0001-clone-nameclash.patch"
+2b6c8186bf2799658494428d68597f63b91799f37809cbe59d8adcab60c27363 0001-clone-nameclash.patch
+c9629e3e5502450ff000af173d568147aee5d8e884d7d8d8754cb7dd94e90ba6 musl-posix-grep.patch"
sha512sums="73dc8c25bc5747fda717d6d2162a8b37bf883544a13b487354a6000d528816a69a021f33cbeec0f6e718a7e9905ab2a04ee63f787ca7f79226055b2da21f4832 graphviz-2.34.0.tar.gz
-aa4cbc341906a949a6bf78cadd96c437d6bcc90369941fe03519aa4447731ecbf6063a0dd0366d3e7aaadf22b69e4bcab3f8632a7da7a01f8e08a3be05c2bc5d 0001-clone-nameclash.patch"
+aa4cbc341906a949a6bf78cadd96c437d6bcc90369941fe03519aa4447731ecbf6063a0dd0366d3e7aaadf22b69e4bcab3f8632a7da7a01f8e08a3be05c2bc5d 0001-clone-nameclash.patch
+365ecb684b26c382f62b2c8bc075169eafd46478d21a49ecc433fcbf7b720027567438a01659fada7714433c1eced7f5662913179e6d59437fc5daba0d66b0cc musl-posix-grep.patch"
diff --git a/main/graphviz/musl-posix-grep.patch b/main/graphviz/musl-posix-grep.patch
new file mode 100644
index 000000000..3cff5feb5
--- /dev/null
+++ b/main/graphviz/musl-posix-grep.patch
@@ -0,0 +1,22 @@
+--- graphviz-2.34.0.orig/Makefile.am
++++ graphviz-2.34.0/Makefile.am
+@@ -31,7 +31,7 @@
+ BUILT_SOURCES = $(top_builddir)/graphviz_version.h
+
+ $(top_builddir)/graphviz_version.h: config.h
+- $(GREP) 'PACKAGE\|VERSION\|GVPLUGIN' config.h > $(top_builddir)/graphviz_version.h
++ $(EGREP) 'PACKAGE|VERSION|GVPLUGIN' config.h > $(top_builddir)/graphviz_version.h
+
+ EXTRA_DIST = $(txt) $(html) graphviz.spec.in graphviz.spec \
+ autogen.sh config/depcomp config/config.rpath \
+--- graphviz-2.34.0.orig/Makefile.in
++++ graphviz-2.34.0/Makefile.in
+@@ -1242,7 +1242,7 @@
+ find $(distdir) -name CVS -type d -prune -exec rm -rf {} \;
+
+ $(top_builddir)/graphviz_version.h: config.h
+- $(GREP) 'PACKAGE\|VERSION\|GVPLUGIN' config.h > $(top_builddir)/graphviz_version.h
++ $(EGREP) 'PACKAGE|VERSION|GVPLUGIN' config.h > $(top_builddir)/graphviz_version.h
+
+ .PHONY: rpm
+ rpm: dist