summaryrefslogtreecommitdiffstats
path: root/main/gst-ffmpeg
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-05-20 08:08:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-05-20 08:08:56 +0000
commitebfda1dde1e15573926b9bd83cae8648c201c85a (patch)
tree216ff78661b8c8d7a18a1f2c8d3cc2bbb7dbec63 /main/gst-ffmpeg
parent2fa58d39ed8589c17c46e87b1745481eb4b43232 (diff)
downloadaports-ebfda1dde1e15573926b9bd83cae8648c201c85a.tar.bz2
aports-ebfda1dde1e15573926b9bd83cae8648c201c85a.tar.xz
main/gst-ffmpeg: disable PIC so we get the mmx stuff
Diffstat (limited to 'main/gst-ffmpeg')
-rw-r--r--main/gst-ffmpeg/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/main/gst-ffmpeg/APKBUILD b/main/gst-ffmpeg/APKBUILD
index d9441e8ca..f376e83c0 100644
--- a/main/gst-ffmpeg/APKBUILD
+++ b/main/gst-ffmpeg/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gst-ffmpeg
pkgver=0.10.10
-pkgrel=1
+pkgrel=2
pkgdesc="Gstreamer FFMpeg Plugin"
url="http://www.gstreamer.net"
license="GPL"
@@ -10,11 +10,12 @@ source="http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-$pkgver.tar.b
build() {
cd "$srcdir"/gst-ffmpeg-$pkgver
- export CFLAGS="$CFLAGS -fno-strict-aliasing"
+ export CFLAGS="$CFLAGS -fno-strict-aliasing -fno-PIC"
+ export LDFLAGS="$LDFLAGS -nopie"
./configure --prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --with-ffmpeg-extra-configure="--enable-pic --disable-mmx --disable-mmx2" || return 1
+ || return 1
make || return 1
}