summaryrefslogtreecommitdiffstats
path: root/main/gtk-vnc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-13 11:51:22 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-13 11:51:22 +0000
commit8c7ada61988d4beb0a2e5f9ad95ec11480f9d361 (patch)
tree977c93d77e156b28406bad12aee250491a33041e /main/gtk-vnc
parent554df9d8b4251b684dc8f141cc4c022f4a585658 (diff)
downloadaports-8c7ada61988d4beb0a2e5f9ad95ec11480f9d361.tar.bz2
aports-8c7ada61988d4beb0a2e5f9ad95ec11480f9d361.tar.xz
main/gtk-vnc: build py-gtk-vnc
Diffstat (limited to 'main/gtk-vnc')
-rw-r--r--main/gtk-vnc/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/main/gtk-vnc/APKBUILD b/main/gtk-vnc/APKBUILD
index 826dd91a4..f36fac206 100644
--- a/main/gtk-vnc/APKBUILD
+++ b/main/gtk-vnc/APKBUILD
@@ -1,15 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtk-vnc
pkgver=0.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="A VNC viewer widget for GTK"
url="http://live.gnome.org/gtk-vnc"
arch="all"
license="LGPL"
-subpackages="$pkgname-dev gvncviewer $pkgname-lang"
+subpackages="$pkgname-dev gvncviewer $pkgname-lang py-$pkgname:py $pkgname-doc"
makedepends="gnutls-dev gtk+-dev libiconv-dev gettext-dev intltool expat-dev
libgcrypt-dev libgpg-error-dev cyrus-sasl-dev perl-text-csv
- gobject-introspection-dev"
+ gobject-introspection-dev python-dev py-gtk-dev py-gobject-dev"
depends_dev="gtk+-dev gnutls-dev"
source="http://ftp.gnome.org/pub/gnome/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
@@ -17,16 +17,18 @@ build ()
{
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr \
- --without-python \
+ --with-python \
--with-examples \
+ --enable-introspection \
--disable-static || return 1
make || return 1
}
package() {
cd "$srcdir"/$pkgname-$pkgver
- make DESTDIR="$pkgdir" install || return 1
- rm "$pkgdir"/usr/lib/*.la
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/lib/python*/site-packages/*.la
}
gvncviewer() {
@@ -35,4 +37,10 @@ gvncviewer() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
+py() {
+ pkgdesc="Python binding for gtk-vnc"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
md5sums="f45c9649c915af335cff91268e74ab67 gtk-vnc-0.5.0.tar.xz"