summaryrefslogtreecommitdiffstats
path: root/main/heimdal
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2010-12-15 13:35:32 +0000
committerLeonardo Arena <rnalrd@gmail.com>2010-12-15 13:35:48 +0000
commit612a6e7c6479acd09214b6d99c95cbdb26d40b90 (patch)
tree75e1d48452a86247b53af3368552de109d17f4c9 /main/heimdal
parent07f10cea7c5ec14e9ddc18575d4a2f2aeea74f0a (diff)
downloadaports-612a6e7c6479acd09214b6d99c95cbdb26d40b90.tar.bz2
aports-612a6e7c6479acd09214b6d99c95cbdb26d40b90.tar.xz
main/heimdal: upgrade to 1.4
Diffstat (limited to 'main/heimdal')
-rw-r--r--main/heimdal/013_all_heimdal-pthread-lib.patch11
-rw-r--r--main/heimdal/APKBUILD44
-rw-r--r--main/heimdal/heimdal-1.4-make.patch88
3 files changed, 107 insertions, 36 deletions
diff --git a/main/heimdal/013_all_heimdal-pthread-lib.patch b/main/heimdal/013_all_heimdal-pthread-lib.patch
deleted file mode 100644
index 19f879407..000000000
--- a/main/heimdal/013_all_heimdal-pthread-lib.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- heimdal-0.7.1/cf/pthreads.m4.old 2005-09-09 12:12:28.000000000 +0000
-+++ heimdal-0.7.1/cf/pthreads.m4 2005-09-17 22:23:23.000000000 +0000
-@@ -32,7 +32,7 @@
- 2.*)
- native_pthread_support=yes
- PTHREADS_CFLAGS=-pthread
-- PTHREADS_LIBS=-pthread
-+ PTHREADS_LIBS=-lpthread
- ;;
- esac
- ;;
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index 36bae5db8..2f7efb84b 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -1,11 +1,10 @@
# Maintainer: Leonardo Arena <rnalrd@gmail.com>
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
pkgname=heimdal
-pkgver=1.3.3
+pkgver=1.4
pkgrel=0
pkgdesc="An implementation of Kerberos 5"
url="http://www.h5l.org/"
-arch="x86 x86_64"
license="BSD"
depends=
makedepends="gawk readline-dev e2fsprogs-dev>=1.41.9-r2 sqlite-dev autoconf automake
@@ -18,45 +17,42 @@ source="http://ftp4.de.freesbie.org/pub/misc/heimdal/src/$pkgname-$pkgver.tar.gz
002_all_heimdal-fPIC.patch
003_all_heimdal-rxapps.patch
005_all_heimdal-suid_fix.patch
-013_all_heimdal-pthread-lib.patch
014_all_heimdal-path.patch
-100-check-com_err-pthread.patch
-heimdal-locate_plugin-header.patch
+heimdal-1.4-make.patch
"
-
# krb5.h needs com_err.h
depends_dev="e2fsprogs-dev"
+_builddir="$srcdir/$pkgname-$pkgver"
+
prepare() {
[ -e /usr/lib/libasn1.so ] && echo "## remove old heimdal pkg first ##" && return 1
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
- patch -Np0 -i ../001_all_heimdal-no_libedit.patch || return 1
- patch -Np0 -i ../002_all_heimdal-fPIC.patch || return 1
- patch -Np0 -i ../003_all_heimdal-rxapps.patch || return 1
- patch -Np0 -i ../005_all_heimdal-suid_fix.patch || return 1
- patch -Np1 -i ../013_all_heimdal-pthread-lib.patch || return 1
- patch -Np0 -i ../014_all_heimdal-path.patch || return 1
- patch -Np1 -i ../100-check-com_err-pthread.patch || return 1
- patch -Np1 -i ../heimdal-locate_plugin-header.patch || return 1
+ for i in ../*.patch
+ do
+ msg "Applying patch $i"
+ patch -p0 -i $i || return 1
+ done
# name clash with ruserpass in netdb.h
sed -i -e 's/ruserpass/ruserpw/g' appl/ftp/ftp/*.[ch] || return 1
- sed -i -e 's|var/heimdal|var/lib/heimdal|g' configure.in \
- doc/setup.texi doc/heimdal.info kadmin/kadmind.8 kdc/kdc.8 \
- lib/hdb/hdb.h lib/krb5/krb5.conf.5 lib/krb5/krb5.conf.cat5
+# sed -i -e 's|var/heimdal|var/lib/heimdal|g' configure.in \
+# doc/setup.texi doc/heimdal.info kadmin/kadmind.8 kdc/kdc.8 \
+# lib/hdb/hdb.h lib/krb5/krb5.conf.5 lib/krb5/krb5.conf.cat5 || return 1
sh ./autogen.sh || return 1
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
export LDFLAGS="${LDFLAGS} -Wl,--as-needed"
./configure --prefix=/usr \
- --enable-shared=yes --without-x \
+ --enable-shared=yes \
+ --without-x \
--disable-berkeley-db \
--with-readline-lib=/usr/lib \
--with-readline-include=/usr/include/readline \
@@ -66,7 +62,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir" exec_prefix=/usr sysconfdir=/etc \
mandir=/usr/share/man infodir=/usr/share/info datadir=/var/lib/heimdal \
localstatedir=/var/lib/heimdal libexecdir=/usr/sbin install
@@ -166,12 +162,10 @@ kf() {
mv $pkgdir/usr/bin/kf $subpkgdir/usr/bin/kf
}
-md5sums="963c09f1b14c41660be70b55fae9f163 heimdal-1.3.3.tar.gz
+md5sums="31d08bbf47a77827fe97ef3f52b4c9c4 heimdal-1.4.tar.gz
98e28f11f906c967aac22d6184102c9e 001_all_heimdal-no_libedit.patch
6d5571bdedba2e2423b90bccdbac2c0a 002_all_heimdal-fPIC.patch
2feec3924ee5230b54175b4d4000c872 003_all_heimdal-rxapps.patch
45aeb207f360f9f4e9e0fabc8bfeecbc 005_all_heimdal-suid_fix.patch
-1b8665b771c4eb6b56ea8582c96e56e3 013_all_heimdal-pthread-lib.patch
8208ae8c0b6ff5ab4f64af1693e9e396 014_all_heimdal-path.patch
-e73205200f9641b5d969427ffb04282a 100-check-com_err-pthread.patch
-248ab80b44568171e432a23524f4fe39 heimdal-locate_plugin-header.patch"
+fa1753ec676029cd59a3ef24da55c144 heimdal-1.4-make.patch"
diff --git a/main/heimdal/heimdal-1.4-make.patch b/main/heimdal/heimdal-1.4-make.patch
new file mode 100644
index 000000000..e49903f27
--- /dev/null
+++ b/main/heimdal/heimdal-1.4-make.patch
@@ -0,0 +1,88 @@
+--- lib/asn1/Makefile.am~ 2010-09-13 09:23:34.000000000 +0200
++++ lib/asn1/Makefile.am 2010-10-02 12:08:31.833815205 +0200
+@@ -641,16 +641,16 @@
+
+ asn1parse.h: asn1parse.c
+
+-$(gen_files_krb5) krb5_asn1.hx krb5_asn1-priv.hx: krb5_asn1_files
+-$(gen_files_pkinit) pkinit_asn1.hx pkinit_asn1-priv.hx: pkinit_asn1_files
+-$(gen_files_pkcs8) pkcs8_asn1.hx pkcs8_asn1-priv.hx: pkcs8_asn1_files
+-$(gen_files_pkcs9) pkcs9_asn1.hx pkcs9_asn1-priv.hx: pkcs9_asn1_files
+-$(gen_files_pkcs12) pkcs12_asn1.hx pkcs12_asn1-priv.hx: pkcs12_asn1_files
+-$(gen_files_digest) digest_asn1.hx digest_asn1-priv.hx: digest_asn1_files
+-$(gen_files_kx509) kx509_asn1.hx kx509_asn1-priv.hx: kx509_asn1_files
+-$(gen_files_rfc2459) rfc2459_asn1.hx rfc2459_asn1-priv.hx: rfc2459_asn1_files
+-$(gen_files_cms) cms_asn1.hx cms_asn1-priv.hx: cms_asn1_files
+-$(gen_files_test) test_asn1.hx test_asn1-priv.hx: test_asn1_files
++$(gen_files_krb5) krb5_asn1.hx krb5_asn1-priv.hx krb5_asn1-template.c: krb5_asn1_files
++$(gen_files_pkinit) pkinit_asn1.hx pkinit_asn1-priv.hx pkinit_asn1-template.c: pkinit_asn1_files
++$(gen_files_pkcs8) pkcs8_asn1.hx pkcs8_asn1-priv.hx pkcs8_asn1-template.c: pkcs8_asn1_files
++$(gen_files_pkcs9) pkcs9_asn1.hx pkcs9_asn1-priv.hx pkcs9_asn1-template.c: pkcs9_asn1_files
++$(gen_files_pkcs12) pkcs12_asn1.hx pkcs12_asn1-priv.hx pkcs12_asn1-template.c: pkcs12_asn1_files
++$(gen_files_digest) digest_asn1.hx digest_asn1-priv.hx digest_asn1-template.c: digest_asn1_files
++$(gen_files_kx509) kx509_asn1.hx kx509_asn1-priv.hx kx509_asn1-template.c: kx509_asn1_files
++$(gen_files_rfc2459) rfc2459_asn1.hx rfc2459_asn1-priv.hx rfc2459_asn1-template.c: rfc2459_asn1_files
++$(gen_files_cms) cms_asn1.hx cms_asn1-priv.hx cms_asn1-template.c: cms_asn1_files
++$(gen_files_test) test_asn1.hx test_asn1-priv.hx test_asn1-template.c: test_asn1_files
+
+ rfc2459_asn1_files: asn1_compile$(EXEEXT) $(srcdir)/rfc2459.asn1
+ $(ASN1_COMPILE) --preserve-binary=TBSCertificate --preserve-binary=TBSCRLCertList --preserve-binary=Name --sequence=GeneralNames --sequence=Extensions --sequence=CRLDistributionPoints $(srcdir)/rfc2459.asn1 rfc2459_asn1 || (rm -f rfc2459_asn1_files ; exit 1)
+--- lib/kadm5/Makefile.am~ 2010-10-14 12:25:00.959390842 +0200
++++ lib/kadm5/Makefile.am 2010-10-14 14:14:14.533473440 +0200
+@@ -159,6 +159,8 @@
+
+ kadm5_err.h: kadm5_err.et
+
++$(dist_libkadm5clnt_la_SOURCES): $(nodist_libkadm5clnt_la_SOURCES)
++
+ $(libkadm5clnt_la_OBJECTS) $(libkadm5srv_la_OBJECTS): $(srcdir)/kadm5-protos.h $(srcdir)/kadm5-private.h
+
+ proto_opts = -q -R '^(_|kadm5_c_|kadm5_s_|kadm5_log)' -P comment
+--- lib/otp/Makefile.am~ 2010-10-02 12:17:36.532815203 +0200
++++ lib/otp/Makefile.am 2010-10-02 12:29:52.970815205 +0200
+@@ -74,3 +74,5 @@
+ strlcpy.c \
+ strlwr.c \
+ strncasecmp.c
++
++EXTRA_DIST = version-script.map
+--- /dev/null 2010-10-02 12:15:38.061000000 +0200
++++ lib/otp/version-script.map 2010-10-02 12:18:06.229815205 +0200
+@@ -0,0 +1,25 @@
++HEIMDAL_OTP_1.0 {
++ global:
++ otp_challenge;
++ otp_checksum;
++ otp_db_close;
++ otp_db_open;
++ otp_delete;
++ otp_error;
++ otp_find_alg;
++ otp_get;
++ otp_parse;
++ otp_parse_altdict;
++ otp_parse_hex;
++ otp_parse_stddict;
++ otp_print_hex;
++ otp_print_hex_extended;
++ otp_print_stddict;
++ otp_print_stddict_extended;
++ otp_put;
++ otp_simple_get;
++ otp_verify_user;
++ otp_verify_user_1;
++ local:
++ *;
++};
+diff --git lib/krb5/version-script.map b/lib/krb5/version-script.map
+index f31620c..39f5146 100644
+--- lib/krb5/version-script.map
++++ lib/krb5/version-script.map
+@@ -105,6 +105,7 @@ HEIMDAL_KRB5_2.0 {
+ krb5_cc_get_type;
+ krb5_cc_get_version;
+ krb5_cc_initialize;
++ krb5_cc_last_change_time;
+ krb5_cc_move;
+ krb5_cc_new_unique;
+ krb5_cc_next_cred;