summaryrefslogtreecommitdiffstats
path: root/main/heimdal
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-11-02 16:01:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-11-02 16:04:10 +0000
commitd7a9a59b3d03981f249b8f1b7c33ce03b8c8e1f7 (patch)
treef6f653572309e5824b085f7f06d66689dee2163e /main/heimdal
parent25d0ce9a2946277dd4309e7e716ade84e1cf67ee (diff)
downloadaports-d7a9a59b3d03981f249b8f1b7c33ce03b8c8e1f7.tar.bz2
aports-d7a9a59b3d03981f249b8f1b7c33ce03b8c8e1f7.tar.xz
main/heimdal: build fix for newer autoconf
patch taken from gentoo rebuild adds pkgconfig as dependency for -dev package
Diffstat (limited to 'main/heimdal')
-rw-r--r--main/heimdal/APKBUILD36
-rw-r--r--main/heimdal/heimdal-autoconf-2.64.patch11
2 files changed, 34 insertions, 13 deletions
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index a494e201a..e717850d6 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
pkgname=heimdal
pkgver=1.2.1
-pkgrel=3
+pkgrel=4
pkgdesc="An implementation of Kerberos 5"
url="http://www.h5l.org/"
license="BSD"
@@ -23,26 +23,28 @@ source="http://www.h5l.org/dist/src/$pkgname-$pkgver.tar.gz
heimdal-system_sqlite.patch
heimdal-r23235-kb5-libwind_la.patch
heimdal-r23238-kb5_locl_h-wind_h.patch
+heimdal-autoconf-2.64.patch
"
# krb5.h needs com_err.h
depends_dev="e2fsprogs-dev"
-build() {
+prepare() {
[ -e /usr/lib/libasn1.so ] && echo "## remove old heimdal pkg first ##" && return 1
cd "$srcdir/$pkgname-$pkgver"
- patch -Np0 -i ../../001_all_heimdal-no_libedit.patch || return 1
- patch -Np0 -i ../../002_all_heimdal-fPIC.patch || return 1
- patch -Np0 -i ../../003_all_heimdal-rxapps.patch || return 1
- patch -Np0 -i ../../005_all_heimdal-suid_fix.patch || return 1
- patch -Np1 -i ../../013_all_heimdal-pthread-lib.patch || return 1
- patch -Np0 -i ../../014_all_heimdal-path.patch || return 1
- patch -Np0 -i ../../022_all_heimdal-as-needed.patch || return 1
- patch -Np0 -i ../../heimdal-system_sqlite.patch || return 1
- patch -Np2 -i ../../heimdal-r23235-kb5-libwind_la.patch || return 1
- patch -Np2 -i ../../heimdal-r23238-kb5_locl_h-wind_h.patch || return 1
+ patch -Np0 -i ../001_all_heimdal-no_libedit.patch || return 1
+ patch -Np0 -i ../002_all_heimdal-fPIC.patch || return 1
+ patch -Np0 -i ../003_all_heimdal-rxapps.patch || return 1
+ patch -Np0 -i ../005_all_heimdal-suid_fix.patch || return 1
+ patch -Np1 -i ../013_all_heimdal-pthread-lib.patch || return 1
+ patch -Np0 -i ../014_all_heimdal-path.patch || return 1
+ patch -Np0 -i ../022_all_heimdal-as-needed.patch || return 1
+ patch -Np0 -i ../heimdal-system_sqlite.patch || return 1
+ patch -Np2 -i ../heimdal-r23235-kb5-libwind_la.patch || return 1
+ patch -Np2 -i ../heimdal-r23238-kb5_locl_h-wind_h.patch || return 1
+ patch -p1 -i ../heimdal-autoconf-2.64.patch || return 1
# name clash with ruserpass in netdb.h
sed -i -e 's/ruserpass/ruserpw/g' appl/ftp/ftp/*.[ch] || return 1
@@ -52,7 +54,10 @@ build() {
lib/hdb/hdb.h lib/krb5/krb5.conf.5 lib/krb5/krb5.conf.cat5
sh ./autogen.sh || return 1
+}
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
export LDFLAGS="${LDFLAGS} -Wl,--as-needed"
./configure --prefix=/usr \
@@ -64,6 +69,10 @@ build() {
--with-openssl=/usr
make || return 1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" exec_prefix=/usr sysconfdir=/etc \
mandir=/usr/share/man infodir=/usr/share/info datadir=/var/lib/heimdal \
localstatedir=/var/lib/heimdal libexecdir=/usr/sbin install
@@ -158,4 +167,5 @@ md5sums="6e5028077e2a6b101a4a72801ba71b9e heimdal-1.2.1.tar.gz
d7649e078c87d2ca997080f0deb527c0 022_all_heimdal-as-needed.patch
949a389ebe7652861b2e178a7e0f1ed9 heimdal-system_sqlite.patch
072f6b2550693adb30117394b1dd354e heimdal-r23235-kb5-libwind_la.patch
-7b4537b0e8bde95214211091e55eacf5 heimdal-r23238-kb5_locl_h-wind_h.patch"
+7b4537b0e8bde95214211091e55eacf5 heimdal-r23238-kb5_locl_h-wind_h.patch
+18826112861b7e47c908b27c90baafac heimdal-autoconf-2.64.patch"
diff --git a/main/heimdal/heimdal-autoconf-2.64.patch b/main/heimdal/heimdal-autoconf-2.64.patch
new file mode 100644
index 000000000..47b02bda7
--- /dev/null
+++ b/main/heimdal/heimdal-autoconf-2.64.patch
@@ -0,0 +1,11 @@
+--- a/cf/roken-frag.m4.orig 2009-08-03 10:40:57.000000000 +0200
++++ b/cf/roken-frag.m4 2009-08-03 10:41:09.000000000 +0200
+@@ -586,7 +586,7 @@
+ #include <err.h>
+ #endif])
+
+-AC_CHECK_DECLS([optarg, optind, opterr, optopt, environ],[],[][
++AC_CHECK_DECLS([optarg, optind, opterr, optopt, environ],[],[],[
+ #include <stdlib.h>
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>