summaryrefslogtreecommitdiffstats
path: root/main/heimdal
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-10 14:54:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-10 14:54:04 +0000
commitf81ee55cee797b4203340cebc3f15691ac93faeb (patch)
treea6c1a11aff21da411d6574ad6a794b119fafce92 /main/heimdal
parent2a47152a439b9747205655ca71541a917bbc6157 (diff)
downloadaports-f81ee55cee797b4203340cebc3f15691ac93faeb.tar.bz2
aports-f81ee55cee797b4203340cebc3f15691ac93faeb.tar.xz
main/heimdal: security fix (CVE-2011-4862)
fixes #912
Diffstat (limited to 'main/heimdal')
-rw-r--r--main/heimdal/APKBUILD6
-rw-r--r--main/heimdal/telnetd.patch14
2 files changed, 18 insertions, 2 deletions
diff --git a/main/heimdal/APKBUILD b/main/heimdal/APKBUILD
index 7e9049659..81b86ba3a 100644
--- a/main/heimdal/APKBUILD
+++ b/main/heimdal/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
pkgname=heimdal
pkgver=1.4
-pkgrel=9
+pkgrel=10
pkgdesc="An implementation of Kerberos 5"
arch="all"
url="http://www.h5l.org/"
@@ -21,6 +21,7 @@ source="http://ftp4.de.freesbie.org/pub/misc/heimdal/src/$pkgname-$pkgver.tar.gz
005_all_heimdal-suid_fix.patch
014_all_heimdal-path.patch
heimdal-1.4-make.patch
+telnetd.patch
"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -172,4 +173,5 @@ md5sums="31d08bbf47a77827fe97ef3f52b4c9c4 heimdal-1.4.tar.gz
2feec3924ee5230b54175b4d4000c872 003_all_heimdal-rxapps.patch
45aeb207f360f9f4e9e0fabc8bfeecbc 005_all_heimdal-suid_fix.patch
8208ae8c0b6ff5ab4f64af1693e9e396 014_all_heimdal-path.patch
-fa1753ec676029cd59a3ef24da55c144 heimdal-1.4-make.patch"
+fa1753ec676029cd59a3ef24da55c144 heimdal-1.4-make.patch
+f320b91692b872e28f446f9cf1bc68bf telnetd.patch"
diff --git a/main/heimdal/telnetd.patch b/main/heimdal/telnetd.patch
new file mode 100644
index 000000000..9c4d10386
--- /dev/null
+++ b/main/heimdal/telnetd.patch
@@ -0,0 +1,14 @@
+Index: crypto/heimdal/appl/telnet/libtelnet/encrypt.c
+===================================================================
+--- appl/telnet/libtelnet/encrypt.c (revision 228798)
++++ appl/telnet/libtelnet/encrypt.c (working copy)
+@@ -736,6 +736,9 @@
+ int dir = kp->dir;
+ int ret = 0;
+
++ if (len > MAXKEYLEN)
++ len = MAXKEYLEN;
++
+ if (!(ep = (*kp->getcrypt)(*kp->modep))) {
+ if (len == 0)
+ return;