summaryrefslogtreecommitdiffstats
path: root/main/hexchat
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-12-19 08:38:15 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-12-19 08:39:59 +0000
commitdd541b27c13886e5393622c81bf06b601e58fc17 (patch)
tree0bdbafb856c351af5fb584c90a81a10d37d82a98 /main/hexchat
parent528798fb3681a64c1345aaa3976ac78f51c330ba (diff)
downloadaports-dd541b27c13886e5393622c81bf06b601e58fc17.tar.bz2
aports-dd541b27c13886e5393622c81bf06b601e58fc17.tar.xz
main/hexchat: moved from testing
Diffstat (limited to 'main/hexchat')
-rw-r--r--main/hexchat/APKBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/main/hexchat/APKBUILD b/main/hexchat/APKBUILD
new file mode 100644
index 000000000..c8a913523
--- /dev/null
+++ b/main/hexchat/APKBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=hexchat
+pkgver=2.9.6.1
+pkgrel=0
+pkgdesc="A popular and easy to use graphical IRC (chat) client"
+url="http://www.hexchat.org"
+arch="all"
+license="GPLv2+"
+depends=""
+makedepends="gtk+2.0-dev openssl-dev dbus-glib-dev perl-dev
+ libsexy-dev python-dev libnotify-dev libproxy-dev
+ bash libtool autoconf automake"
+install=""
+subpackages="$pkgname-doc $pkgname-lang $pkgname-python:_python"
+source="http://dl.hexchat.org/hexchat/hexchat-$pkgver.tar.xz"
+
+_builddir="$srcdir"/hexchat-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-openssl \
+ --enable-dbus \
+ --disable-textfe \
+ --disable-perl \
+ --enable-python \
+ --enable-ipv6 \
+ --enable-shm \
+ --enable-spell=libsexy || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/hexchat/plugins/*.la || return 1
+ # not worth a -dev pkg
+ rm -r "$pkgdir"/usr/include
+}
+
+_python() {
+ pkgdesc="Python plugin for hexchat"
+ mkdir -p "$subpkgdir"/usr/lib/hexchat/plugins
+ mv "$pkgdir"/usr/lib/hexchat/plugins/python.so \
+ "$subpkgdir"/usr/lib/hexchat/plugins
+}
+
+md5sums="4723f43afc65a973ceddbea0173ff416 hexchat-2.9.6.1.tar.xz"
+sha256sums="6267ff3c4d0aec8a808365b384115a769d5001d99dbb10403634667c43966470 hexchat-2.9.6.1.tar.xz"
+sha512sums="73a7c2818b9d59a62c2471b9010cd04a6a5ac85b22d5158fdc27831d8700f09eb3011aac341866b76d7a4efe483f59de9c7b6d9a983916ccfbf8e61db81ea195 hexchat-2.9.6.1.tar.xz"