summaryrefslogtreecommitdiffstats
path: root/main/hypermail
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2010-02-12 21:12:57 +0000
committerMichael Mason <ms13sp@gmail.com>2010-03-08 20:57:31 +0000
commit9a2bbde4c364ec96aaf800a320d95b879985ee2f (patch)
tree7c0a45471cc4e9b6b9fcfcf28ec0df7f8d9eca1c /main/hypermail
parent08d591b04acf41d5cdbc6d3c7c4206f2793e8d72 (diff)
downloadaports-9a2bbde4c364ec96aaf800a320d95b879985ee2f.tar.bz2
aports-9a2bbde4c364ec96aaf800a320d95b879985ee2f.tar.xz
main/hypermail Updated. mdri2mbox.lua fix with patch from nangel@nothome.org
Diffstat (limited to 'main/hypermail')
-rw-r--r--main/hypermail/APKBUILD2
-rw-r--r--main/hypermail/mdir2mbox.lua2
2 files changed, 2 insertions, 2 deletions
diff --git a/main/hypermail/APKBUILD b/main/hypermail/APKBUILD
index 82ea75257..a1b02406c 100644
--- a/main/hypermail/APKBUILD
+++ b/main/hypermail/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=hypermail
pkgver=2.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Mail Archiver"
url="http://www.hypermail-project.org"
license="GPL"
diff --git a/main/hypermail/mdir2mbox.lua b/main/hypermail/mdir2mbox.lua
index dd883e02d..1a8416bad 100644
--- a/main/hypermail/mdir2mbox.lua
+++ b/main/hypermail/mdir2mbox.lua
@@ -70,7 +70,7 @@ file_to_mbox = function (path)
local date = string.match("\n" .. headers, "\nDate: ([^\n]*)")
if date == nil then
- date = os.date ("%c", posix.stat(path, "mtime"))
+ date = os.date ("%a, %d %b %Y %X +%z", posix.stat(path, "mtime"))
end
local weekday,day,month,year,time,offset = string.match(date, "([^,]*), +(%d+) (%a+) (%d+) ([%d:]*) ([%d]*)")