summaryrefslogtreecommitdiffstats
path: root/main/iceauth
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 08:45:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 08:47:22 +0000
commit8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc (patch)
treee1bdd0bbb491926306c1e43e72dabbbe235f4b62 /main/iceauth
parent832a032dd3794c5cc3e67f4ee580e171996e8e29 (diff)
downloadaports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.bz2
aports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.xz
main/[various]: update config.sub (and remove charset.alias)
for musl build. the changes are automatically done based on previous build log errors, so this does not guarantee successful build, but is a required.
Diffstat (limited to 'main/iceauth')
-rw-r--r--main/iceauth/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/iceauth/APKBUILD b/main/iceauth/APKBUILD
index 77fad92b3..d75a8e9da 100644
--- a/main/iceauth/APKBUILD
+++ b/main/iceauth/APKBUILD
@@ -10,8 +10,15 @@ subpackages="$pkgname-doc"
depends=
makedepends="pkgconfig libice-dev"
source="http://xorg.freedesktop.org/releases/individual/app/iceauth-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -22,7 +29,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="975ade3f238c1eb10705da0a91e6e8e7 iceauth-1.0.3.tar.bz2"