summaryrefslogtreecommitdiffstats
path: root/main/icedtea-web
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-04-02 07:21:17 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-04-02 07:21:17 -0500
commit72f09f93efa6b6b6992c12303d14f1ec229bb01c (patch)
treeeb36ad368e6611f2d6afdb753d97075d5950b57c /main/icedtea-web
parentaa189282f59531f5ce70cb3bfe88a914ddcd9abb (diff)
downloadaports-72f09f93efa6b6b6992c12303d14f1ec229bb01c.tar.bz2
aports-72f09f93efa6b6b6992c12303d14f1ec229bb01c.tar.xz
main/icedtea-web: new aport
Diffstat (limited to 'main/icedtea-web')
-rw-r--r--main/icedtea-web/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/main/icedtea-web/APKBUILD b/main/icedtea-web/APKBUILD
new file mode 100644
index 000000000..d08140dd4
--- /dev/null
+++ b/main/icedtea-web/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=icedtea-web
+pkgver=1.0.1
+pkgrel=0
+pkgdesc="web integration packages for icedtea"
+url="http://icedtea.classpath.org/wiki/IcedTea-Web"
+arch="all"
+license="GPL"
+depends=
+depends_dev="xulrunner-dev openjdk6 openjdk6-jre"
+makedepends="tar zip $depends_dev"
+install=""
+subpackages="$pkgname-mozilla $pkgname-doc"
+source="http://icedtea.classpath.org/download/source/icedtea-web-$pkgver.tar.gz"
+
+CPU=`uname -m | sed -e 's/i.86/i386/g' -e 's/x86_64/amd64/g'`
+
+_builddir="$srcdir"/icedtea-web-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr/lib/jvm/java-1.6-openjdk \
+ --datarootdir=/usr/share \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --with-jdk-home=/usr/lib/jvm/java-1.6-openjdk \
+ --with-pkgversion=Alpine \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+mozilla() {
+ mkdir -p "$subpkgdir"/usr/lib/mozilla/plugins
+ mkdir -p "$subpkgdir"/usr/lib/jvm/java-1.6-openjdk/jre/lib/$CPU
+ mv "$pkgdir"/usr/lib/jvm/java-1.6-openjdk/jre/lib/$CPU/IcedTeaPlugin.so \
+ "$subpkgdir"/usr/lib/jvm/java-1.6-openjdk/jre/lib/$CPU
+ ln -sf /usr/lib/jvm/java-1.6-openjdk/jre/lib/$CPU/IcedTeaPlugin.so \
+ "$subpkgdir"/usr/lib/mozilla/plugins/libjavaplugin.so
+ return 0
+}
+
+md5sums="30f969de0503a296226ae0a1876f9702 icedtea-web-1.0.1.tar.gz"