summaryrefslogtreecommitdiffstats
path: root/main/imagemagick
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2014-01-22 22:02:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-03-03 13:03:40 +0000
commit48e547de24f5518ed9a5bd20ed742b9d3ef076ea (patch)
tree2951a760dff0ba28cb226cd294a6d43c96bed74a /main/imagemagick
parent969976286c20a45d6ba8d04179adea29460f13e5 (diff)
downloadaports-48e547de24f5518ed9a5bd20ed742b9d3ef076ea.tar.bz2
aports-48e547de24f5518ed9a5bd20ed742b9d3ef076ea.tar.xz
main/imagemagick: merge
Diffstat (limited to 'main/imagemagick')
-rw-r--r--main/imagemagick/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/main/imagemagick/APKBUILD b/main/imagemagick/APKBUILD
index 2a319b085..0e423f515 100644
--- a/main/imagemagick/APKBUILD
+++ b/main/imagemagick/APKBUILD
@@ -8,16 +8,17 @@ pkgrel=1
pkgdesc="A collection of tools and libraries for many image formats"
url="http://www.imagemagick.org/"
arch="all"
-license="GPL"
-depends=
+license="custom"
+depends=""
options="libtool"
makedepends="zlib-dev libpng-dev libjpeg-turbo-dev freetype-dev perl-dev
ghostscript-dev libwebp-dev libtool"
subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx"
source="ftp://ftp.imagemagick.org/pub/ImageMagick/ImageMagick-$_pkgver.tar.xz"
+_builddir="$srcdir/ImageMagick-${_pkgver}"
prepare() {
- cd "$srcdir/ImageMagick-${_pkgver}"
+ cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
@@ -26,8 +27,7 @@ prepare() {
}
build() {
- cd "$srcdir/ImageMagick-${_pkgver}"
-
+ cd "$_builddir"
# fix doc dir, Gentoo bug 91911
sed -i -e \
's:DOCUMENTATION_PATH="${DATA_DIR}/doc/${DOCUMENTATION_RELATIVE_PATH}":DOCUMENTATION_PATH="/usr/share/doc/imagemagick":g' \
@@ -51,8 +51,8 @@ build() {
}
package() {
- cd "$srcdir/ImageMagick-${_pkgver}"
- make -j1 DESTDIR="$pkgdir" install
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
if ! [ -e "$pkgdir"/usr/lib/libMagickCore-$_abiver.Q16.so ]; then
error "Has ABI verision changed? (current is $_abiver)"
return 1
@@ -60,6 +60,8 @@ package() {
find "$pkgdir" -name '.packlist' -o -name 'perllocal.pod' \
-o -name '*.bs' -delete
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE || return 1
}
_cxx() {