summaryrefslogtreecommitdiffstats
path: root/main/jwhois
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-01-12 07:17:43 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-01-12 07:17:43 -0600
commitde483182249bdbf22d7a7af4c976fd6a0721a0ec (patch)
tree51c853a748b2d3f1f0553e0353472559da8a260d /main/jwhois
parentffd9b4d4c06787418754013f906f3e13fdf1173c (diff)
downloadaports-de483182249bdbf22d7a7af4c976fd6a0721a0ec.tar.bz2
aports-de483182249bdbf22d7a7af4c976fd6a0721a0ec.tar.xz
main/jwhois: promoted to main from testing
Diffstat (limited to 'main/jwhois')
-rw-r--r--main/jwhois/APKBUILD41
-rw-r--r--main/jwhois/jwhois-libiconv.patch10
2 files changed, 51 insertions, 0 deletions
diff --git a/main/jwhois/APKBUILD b/main/jwhois/APKBUILD
new file mode 100644
index 000000000..d2fbc460c
--- /dev/null
+++ b/main/jwhois/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=jwhois
+pkgver=4.0
+pkgrel=1
+pkgdesc="WHOIS/RWHOIS client"
+url="http://www.gnu.org/software/jwhois/"
+license="GPL"
+depends=
+makedepends="libiconv-dev autoconf automake libtool"
+install=
+subpackages="$pkgname-doc"
+source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz
+ jwhois-libiconv.patch"
+arch="all"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ patch -p1 < "$srcdir/jwhois-libiconv.patch"
+ autoreconf
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/ \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-nls \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="977d0ba90ee058a7998c94d933fc9546 jwhois-4.0.tar.gz
+f861d1891a718f3b370e1ac032b0b337 jwhois-libiconv.patch"
diff --git a/main/jwhois/jwhois-libiconv.patch b/main/jwhois/jwhois-libiconv.patch
new file mode 100644
index 000000000..31c54bdf4
--- /dev/null
+++ b/main/jwhois/jwhois-libiconv.patch
@@ -0,0 +1,10 @@
+--- jwhois-4.0/src/Makefile.am
++++ jwhois-4.0.mod/src/Makefile.am
+@@ -23,6 +23,7 @@
+ getopt.c getopt1.c jconfig.c string.c cache.c rwhois.c jwhois.c \
+ whois.c http.c
+
++LIBS += @LIBICONV@
+ jwhois_LIBS = @LIBINTL@ @LIBICONV@ @LIBS@
+
+ jwhois_CFLAGS = $(OLDCFLAGS) -DSYSCONFDIR="\"$(sysconfdir)\"" \