summaryrefslogtreecommitdiffstats
path: root/main/libestr
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-30 11:11:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-30 11:11:39 +0000
commit2810f5b0c13ddc9697be7af31248a15f733f4b2f (patch)
tree42807c6a272f759d9f261512ba092ca2c9c9356e /main/libestr
parent9976f92efb3566e0917f0d405919188617e9e407 (diff)
downloadaports-2810f5b0c13ddc9697be7af31248a15f733f4b2f.tar.bz2
aports-2810f5b0c13ddc9697be7af31248a15f733f4b2f.tar.xz
main/libestr: moved from testing
needed by rsyslog
Diffstat (limited to 'main/libestr')
-rw-r--r--main/libestr/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/main/libestr/APKBUILD b/main/libestr/APKBUILD
new file mode 100644
index 000000000..3ce89068d
--- /dev/null
+++ b/main/libestr/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Uros
+# Maintainer: Cameron Banta <cbanta@gmail.com>
+pkgname=libestr
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="essentials for string handling (and a bit more)"
+url="http://libestr.adiscon.com"
+arch="all"
+license="LGPL2.1"
+subpackages="$pkgname-dev"
+source="http://libestr.adiscon.com/files/download/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -rf "$pkgdir"/usr/lib/libestr.la
+}
+
+md5sums="30ec4054155dc7d7e9b06418181c4f12 libestr-0.1.2.tar.gz"