summaryrefslogtreecommitdiffstats
path: root/main/libevent
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-20 13:01:09 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-20 13:02:19 +0000
commit2702db2a9ba4bb1f2ef819ae61c791477748784f (patch)
treedc7fdfaec5296561ff80bbd973d9470b4d641cd4 /main/libevent
parent5d990086ddb19bc28eb4a2d43c65f2d1bcdd739d (diff)
downloadaports-2702db2a9ba4bb1f2ef819ae61c791477748784f.tar.bz2
aports-2702db2a9ba4bb1f2ef819ae61c791477748784f.tar.xz
main/[various]: simple build fixes against musl (update_config_sub)
Diffstat (limited to 'main/libevent')
-rw-r--r--main/libevent/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/main/libevent/APKBUILD b/main/libevent/APKBUILD
index f031f8cb3..b4a933d9b 100644
--- a/main/libevent/APKBUILD
+++ b/main/libevent/APKBUILD
@@ -13,6 +13,11 @@ subpackages="$pkgname-dev"
source="https://github.com/downloads/libevent/libevent/libevent-$pkgver-stable.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver-stable
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
cd "$_builddir"
./configure \