summaryrefslogtreecommitdiffstats
path: root/main/libical
diff options
context:
space:
mode:
authorAndrew Manison <amanison@anselsystems.com>2010-06-19 09:02:05 +0000
committerAndrew Manison <amanison@anselsystems.com>2010-06-19 09:02:05 +0000
commit85fd77589be2f6c970ca6895afa1520e0a2fda04 (patch)
tree6b9d172b005b2657e541424da71009dcd2a1f3c4 /main/libical
parent8fdcdf953f865c691b01d546a0baea1a1143deeb (diff)
parent253afa4a86bcb0959ca8b7fb269f482058847a9b (diff)
downloadaports-85fd77589be2f6c970ca6895afa1520e0a2fda04.tar.bz2
aports-85fd77589be2f6c970ca6895afa1520e0a2fda04.tar.xz
Merge remote branch 'alpine/master'
Conflicts: main/openssl/APKBUILD
Diffstat (limited to 'main/libical')
-rw-r--r--main/libical/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/main/libical/APKBUILD b/main/libical/APKBUILD
new file mode 100644
index 000000000..22ef96784
--- /dev/null
+++ b/main/libical/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libical
+pkgver=0.44
+pkgrel=0
+pkgdesc="An open source reference implementation of the icalendar data type and serialization format"
+url="http://sourceforge.net/projects/freeassociation/"
+license="LGPL MPL"
+depends=
+makedepends="perl"
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/freeassociation/$pkgname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --enable-shared \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+md5sums="e0403c31e1ed82569325685f8c15959c libical-0.44.tar.gz"