summaryrefslogtreecommitdiffstats
path: root/main/libsexy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/libsexy
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
downloadaports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.bz2
aports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.xz
merged x11 repository into main
ref #255
Diffstat (limited to 'main/libsexy')
-rw-r--r--main/libsexy/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/main/libsexy/APKBUILD b/main/libsexy/APKBUILD
new file mode 100644
index 000000000..64488a0ad
--- /dev/null
+++ b/main/libsexy/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsexy
+pkgver=0.1.11
+pkgrel=0
+pkgdesc="Doing naughty things to good widgets."
+url="http://chipx86.com/wiki/Libsexy"
+license="GPL"
+subpackages="$pkgname-dev $pkgname-doc"
+makedepends="gtk+-dev libxml2-dev iso-codes"
+source="http://releases.chipx86.com/$pkgname/$pkgname/$pkgname-$pkgver.tar.gz"
+
+build ()
+{
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --disable-static
+ make || return 1
+ make DESTDIR="$pkgdir" install
+ rm -f "$pkgdir"/usr/lib/libsexy.a
+}
+
+md5sums="33c079a253270ec8bfb9508e4bb30754 libsexy-0.1.11.tar.gz"