summaryrefslogtreecommitdiffstats
path: root/main/libusbx
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-09-30 07:06:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-09-30 07:09:22 +0000
commit5684ca74c749ce27879af53e4c7f5e589627280f (patch)
treeba981052e2185a7664d161f158e3770a7da9b89a /main/libusbx
parent3cbacc3c5e414a58ae215445519eb46db4921e08 (diff)
downloadaports-5684ca74c749ce27879af53e4c7f5e589627280f.tar.bz2
aports-5684ca74c749ce27879af53e4c7f5e589627280f.tar.xz
main/libusbx: disable udev
It looks like udev is only used for listening to hotplug events and to parse the sys_name, devaddr and bus num info. If udev is disabled it will listen directly to a netlink socket. We disable udev to prevent circular dependency.
Diffstat (limited to 'main/libusbx')
-rw-r--r--main/libusbx/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/libusbx/APKBUILD b/main/libusbx/APKBUILD
index 060b790f7..f6d121c36 100644
--- a/main/libusbx/APKBUILD
+++ b/main/libusbx/APKBUILD
@@ -2,14 +2,14 @@
pkgname=libusbx
pkgver=1.0.17
_ver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="Library to enable user space application programs to communicate with USB devices"
url="http://libusb.sourceforge.net/"
arch="all"
license="LGPL2+"
subpackages="$pkgname-dev"
replaces="libusb"
-makedepends="udev-dev"
+makedepends=""
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2"
_builddir="$srcdir"/$pkgname-$_ver
@@ -19,6 +19,7 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
+ --disable-udev \
|| return 1
make || return 1
}