summaryrefslogtreecommitdiffstats
path: root/main/libxml2
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2010-05-12 10:43:39 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2010-05-12 10:43:39 +0000
commit28915d9d49091b82f94b72502fe2071919b80ec7 (patch)
treea7e4a1c403cc81d707a3582f243284014826964f /main/libxml2
parent8e0d1d48946e43ca3bd83dd41eda1275f81e21a0 (diff)
downloadaports-28915d9d49091b82f94b72502fe2071919b80ec7.tar.bz2
aports-28915d9d49091b82f94b72502fe2071919b80ec7.tar.xz
main/libxml2: upgrade to 2.7.7
Diffstat (limited to 'main/libxml2')
-rw-r--r--main/libxml2/APKBUILD12
-rw-r--r--main/libxml2/zlib.patch32
2 files changed, 5 insertions, 39 deletions
diff --git a/main/libxml2/APKBUILD b/main/libxml2/APKBUILD
index 4843af7ad..6c314eb56 100644
--- a/main/libxml2/APKBUILD
+++ b/main/libxml2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Carlo Landmeter <clandmeter at gmail>
# Maintainer: Carlo Landmeter <clandmeter at gmail>
pkgname=libxml2
-pkgver=2.7.6
-pkgrel=3
+pkgver=2.7.7
+pkgrel=0
pkgdesc="XML parsing library, version 2"
url="http://www.xmlsoft.org/"
license="MIT"
@@ -10,8 +10,7 @@ depends=
makedepends="zlib-dev python-dev"
subpackages="$pkgname-doc $pkgname-dev py-$pkgname:py"
source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
- largefile64.patch
- zlib.patch"
+ largefile64.patch"
options="!strip"
@@ -46,6 +45,5 @@ py() {
}
-md5sums="7740a8ec23878a2f50120e1faa2730f2 libxml2-2.7.6.tar.gz
-5ad4915665608ebfa5b89f7908467a72 largefile64.patch
-0365d5397164b8739219e56e5ca069d1 zlib.patch"
+md5sums="9abc9959823ca9ff904f1fbcf21df066 libxml2-2.7.7.tar.gz
+5ad4915665608ebfa5b89f7908467a72 largefile64.patch"
diff --git a/main/libxml2/zlib.patch b/main/libxml2/zlib.patch
deleted file mode 100644
index 4bf486d12..000000000
--- a/main/libxml2/zlib.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From a7e79f28689c574e0bbef17f4cb3da00249181ff Mon Sep 17 00:00:00 2001
-From: Mark Adler <madler@alumni.caltech.edu>
-Date: Tue, 19 Jan 2010 15:28:48 +0000
-Subject: libxml violates the zlib interface and crashes
-
-* xmlIO.c: remove an abuse of zlib API and use a clean interface
- available in zlib >= 1.2.3
----
-diff --git a/xmlIO.c b/xmlIO.c
-index c03ac43..8fc00e3 100644
---- a/xmlIO.c
-+++ b/xmlIO.c
-@@ -2518,6 +2518,9 @@ __xmlParserInputBufferCreateFilename(const char *URI, xmlCharEncoding enc) {
- #ifdef HAVE_ZLIB_H
- if ((xmlInputCallbackTable[i].opencallback == xmlGzfileOpen) &&
- (strcmp(URI, "-") != 0)) {
-+#if defined(ZLIB_VERNUM) && ZLIB_VERNUM >= 0x1230
-+ ret->compressed = !gzdirect(context);
-+#else
- if (((z_stream *)context)->avail_in > 4) {
- char *cptr, buff4[4];
- cptr = (char *) ((z_stream *)context)->next_in;
-@@ -2529,6 +2532,7 @@ __xmlParserInputBufferCreateFilename(const char *URI, xmlCharEncoding enc) {
- gzrewind(context);
- }
- }
-+#endif
- }
- #endif
- }
---
-cgit v0.8.3.1