summaryrefslogtreecommitdiffstats
path: root/main/lighttpd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-07-18 12:21:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-07-18 12:53:29 +0000
commit30d6c8c7a3d6c2ebea1e0f1d2c059e163c2a6a60 (patch)
tree0932dd5bdc3db44b32ce249516695e268f67ba4e /main/lighttpd
parentb8b4953ab03d1e94abee1410151cee80d88325ed (diff)
downloadaports-30d6c8c7a3d6c2ebea1e0f1d2c059e163c2a6a60.tar.bz2
aports-30d6c8c7a3d6c2ebea1e0f1d2c059e163c2a6a60.tar.xz
main/lighttpd: add webdav support and reorganize
- rename lighttpd-264_streaming to lighttpd-mod_264_streaming - move mod_auth to subpackage. This removes libldap dependency - add mod_webdav subpackage
Diffstat (limited to 'main/lighttpd')
-rw-r--r--main/lighttpd/APKBUILD39
1 files changed, 30 insertions, 9 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index 7154931f3..3187b0cde 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lighttpd
pkgver=1.4.29
_streamver=2.2.0
-pkgrel=0
+pkgrel=1
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
arch="all"
@@ -10,7 +10,7 @@ license="custom"
install="$pkgname.pre-install $pkgname.post-install"
depends=
makedepends="flex pcre-dev openssl-dev zlib-dev bzip2-dev lua-dev pkgconfig
- automake autoconf openldap-dev"
+ automake autoconf openldap-dev libxml2-dev sqlite-dev"
source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.tar.bz2
http://h264.code-shop.com/download/lighttpd-1.4.18_mod_h264_streaming-$_streamver.tar.gz
$pkgname.initd
@@ -24,7 +24,8 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
mod_fastcgi.conf
mod_fastcgi_fpm.conf
"
-subpackages="$pkgname-doc $pkgname-h264_streaming"
+subpackages="$pkgname-doc $pkgname-mod_auth $pkgname-mod_h264_streaming
+ $pkgname-mod_webdav"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
@@ -48,14 +49,15 @@ build() {
local i
cd "$srcdir"/$pkgname-$pkgver
./configure --prefix=/usr \
+ --disable-dependency-tracking \
--enable-lfs \
--libdir=/usr/lib/lighttpd \
--without-mysql \
--without-attr \
--without-kerberos5 \
--without-fam \
- --without-webdav-props \
- --without-webdav-locks \
+ --with-webdav-props \
+ --with-webdav-locks \
--without-gdbm \
--without-memcache \
--with-bzip2 \
@@ -95,15 +97,34 @@ package() {
done
}
-h264_streaming() {
+_mv_mod() {
+ mkdir -p "$subpkgdir"/usr/lib/lighttpd
+ while [ $# -gt 0 ]; do
+ mv "$pkgdir"/usr/lib/lighttpd/$1.so \
+ "$subpkgdir"/usr/lib/lighttpd/ || return 1
+ shift
+ done
+}
+
+mod_h264_streaming() {
pkgdesc="H264 Streaming Module for lighttpd"
url="http://h264.code-shop.com/trac"
license="CCPL-nc-sa-3.0"
- mkdir -p "$subpkgdir"/usr/lib/lighttpd
- mv "$pkgdir"/usr/lib/lighttpd/mod_h264_streaming.so \
- "$subpkgdir"/usr/lib/lighttpd/
+ replaces="lighttpd-h264_streaming"
+ _mv_mod mod_h264_streaming
}
+mod_auth() {
+ pkgdesc="Authentication module for lighttpd"
+ _mv_mod mod_auth
+}
+
+mod_webdav() {
+ pkgdesc="WebDAV module for lighttpd"
+ _mv_mod mod_webdav
+}
+
+
md5sums="e6e67b09986cb504db630b5a86b2dd76 lighttpd-1.4.29.tar.bz2
ac37885c881a058194405232e7737a7a lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
e37770e4eed20390806a2420a3970fcd lighttpd.initd