summaryrefslogtreecommitdiffstats
path: root/main/lighttpd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-11 13:41:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-11 13:41:51 +0000
commit6541bb857f114f70334258d87892d03d34f4d775 (patch)
treeb103c18d6cae369f168d14bb137b3d18af28ea99 /main/lighttpd
parentc2ab6b6031cccc0d48c525541bdd10d57d18b3b4 (diff)
downloadaports-6541bb857f114f70334258d87892d03d34f4d775.tar.bz2
aports-6541bb857f114f70334258d87892d03d34f4d775.tar.xz
main/lighttpd: added h264 streaming module
http://h264.code-shop.com/trac/wiki
Diffstat (limited to 'main/lighttpd')
-rw-r--r--main/lighttpd/APKBUILD26
1 files changed, 24 insertions, 2 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index aa178e2bb..2173b63e2 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -1,14 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lighttpd
pkgver=1.4.25
-pkgrel=0
+_streamver=2.2.0
+pkgrel=1
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
license="custom"
install="$pkgname.pre-install $pkgname.post-install"
depends=
-makedepends="flex pcre-dev openssl-dev zlib-dev bzip2-dev lua-dev pkgconfig"
+makedepends="flex pcre-dev openssl-dev zlib-dev bzip2-dev lua-dev pkgconfig
+ automake autoconf"
source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.tar.bz2
+ http://h264.code-shop.com/download/lighttpd-1.4.18_mod_h264_streaming-$_streamver.tar.gz
$pkgname.initd
$pkgname.confd
$pkgname.logrotate
@@ -21,6 +24,24 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
"
subpackages="$pkgname-dev $pkgname-doc"
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ # copy over the mod-h264-streaming mod
+ # http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
+ cp "$srcdir"/lighttpd-1.4.18/src/moov.* src/
+ cp "$srcdir"/lighttpd-1.4.18/src/mod_h264_streaming.c src/
+
+ cat >> src/Makefile.am <<__EOF__
+
+lib_LTLIBRARIES += mod_h264_streaming.la
+mod_h264_streaming_la_SOURCES = mod_h264_streaming.c moov.c
+mod_h264_streaming_la_LDFLAGS = -module -export-dynamic -avoid-version -no-undefined
+mod_h264_streaming_la_LIBADD = \$(common_libadd)
+__EOF__
+ aclocal -I m4 && autoconf && automake
+}
+
build() {
local i
cd "$srcdir"/$pkgname-$pkgver
@@ -71,6 +92,7 @@ package() {
done
}
md5sums="2027c49fb46530e45338c5e2da13c02f lighttpd-1.4.25.tar.bz2
+ac37885c881a058194405232e7737a7a lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
36c4ddbc266017dc193fcb0cdd1d84e1 lighttpd.initd
0dede109282bfe685bdec6b35f0e4b6b lighttpd.confd
ad091c9157134890499f26d170352c9f lighttpd.logrotate