summaryrefslogtreecommitdiffstats
path: root/main/lighttpd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-16 12:30:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-16 12:30:54 +0000
commitcb4d2363ba3375e38638c0f75e71c05b86d4746b (patch)
tree9e3be174f5945ca58f6b789de3f99a3bc13a9d25 /main/lighttpd
parenta8887daa9e47b3670ea70186851c9ab72de0e9ce (diff)
downloadaports-cb4d2363ba3375e38638c0f75e71c05b86d4746b.tar.bz2
aports-cb4d2363ba3375e38638c0f75e71c05b86d4746b.tar.xz
main/lighttp: upgrade to 1.4.27
Diffstat (limited to 'main/lighttpd')
-rw-r--r--main/lighttpd/APKBUILD18
-rw-r--r--main/lighttpd/fix-handling-return-value-of-SSL_CTX_set_options.patch13
-rw-r--r--main/lighttpd/lighttpd-version-from-git.patch13
3 files changed, 4 insertions, 40 deletions
diff --git a/main/lighttpd/APKBUILD b/main/lighttpd/APKBUILD
index f229887b2..75b11087c 100644
--- a/main/lighttpd/APKBUILD
+++ b/main/lighttpd/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lighttpd
-pkgver=1.4.26
+pkgver=1.4.27
_streamver=2.2.0
-pkgrel=5
+pkgrel=0
pkgdesc="a secure, fast, compliant and very flexible web-server"
url="http://www.lighttpd.net/"
license="custom"
@@ -21,20 +21,12 @@ source="http://download.lighttpd.net/lighttpd/releases-1.4.x/$pkgname-$pkgver.ta
mime-types.conf
mod_cgi.conf
mod_fastcgi.conf
- lighttpd-version-from-git.patch
- fix-handling-return-value-of-SSL_CTX_set_options.patch
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-h264_streaming"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
- # http://bugs.alpinelinux.org/issues/323
- patch -p0 -i "$srcdir"/lighttpd-version-from-git.patch || return 1
-
- # http://bugs.alpinelinux.org/issues/329
- patch -p2 -i "$srcdir"/fix-handling-return-value-of-SSL_CTX_set_options.patch || return 1
-
# copy over the mod-h264-streaming mod
# http://h264.code-shop.com/trac/wiki/Mod-H264-Streaming-Lighttpd-Version2#DownloadLighttpd1.4.191.4.20andother1.4.x
cp "$srcdir"/lighttpd-1.4.18/src/moov.* src/
@@ -109,7 +101,7 @@ h264_streaming() {
"$subpkgdir"/usr/lib/lighttpd/
}
-md5sums="a682c8efce47a2f4263a247ba0813c9b lighttpd-1.4.26.tar.bz2
+md5sums="afece7dc547d71cb94ea2e34ee5b3f9b lighttpd-1.4.27.tar.bz2
ac37885c881a058194405232e7737a7a lighttpd-1.4.18_mod_h264_streaming-2.2.0.tar.gz
36c4ddbc266017dc193fcb0cdd1d84e1 lighttpd.initd
0dede109282bfe685bdec6b35f0e4b6b lighttpd.confd
@@ -119,6 +111,4 @@ ad091c9157134890499f26d170352c9f lighttpd.logrotate
df5b2360ea380d988bf16905ab214286 lighttpd.conf
fef397e7bcf1b741dea211a555e1803c mime-types.conf
9c1407e95f62ed22da66c4ef5f69c3b5 mod_cgi.conf
-f3363e39832f1b6678468b482d121afb mod_fastcgi.conf
-c2471f50eec2ce85da6dfaf8289725bc lighttpd-version-from-git.patch
-770baaa9a8dae51e25db29d3561d5b76 fix-handling-return-value-of-SSL_CTX_set_options.patch"
+f3363e39832f1b6678468b482d121afb mod_fastcgi.conf"
diff --git a/main/lighttpd/fix-handling-return-value-of-SSL_CTX_set_options.patch b/main/lighttpd/fix-handling-return-value-of-SSL_CTX_set_options.patch
deleted file mode 100644
index 40eab25e5..000000000
--- a/main/lighttpd/fix-handling-return-value-of-SSL_CTX_set_options.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: branches/lighttpd-1.4.x/src/network.c
-===================================================================
---- branches/lighttpd-1.4.x/src/network.c (revision 2715)
-+++ branches/lighttpd-1.4.x/src/network.c (revision 2716)
-@@ -525,7 +525,7 @@
-
- if (!s->ssl_use_sslv2) {
- /* disable SSLv2 */
-- if (SSL_OP_NO_SSLv2 != SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2)) {
-+ if (!(SSL_OP_NO_SSLv2 & SSL_CTX_set_options(s->ssl_ctx, SSL_OP_NO_SSLv2))) {
- log_error_write(srv, __FILE__, __LINE__, "ss", "SSL:",
- ERR_error_string(ERR_get_error(), NULL));
- return -1;
diff --git a/main/lighttpd/lighttpd-version-from-git.patch b/main/lighttpd/lighttpd-version-from-git.patch
deleted file mode 100644
index ae6407c49..000000000
--- a/main/lighttpd/lighttpd-version-from-git.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: src/Makefile.am
-===================================================================
---- src/Makefile.am (revision 2717)
-+++ src/Makefile.am (working copy)
-@@ -19,7 +19,7 @@
- REVISION=""; \
- fi; \
- fi; \
-- if test -z "$$REVISION" -a -x "`which git`"; then \
-+ if test -z "$$REVISION" -a -d "$(top_srcdir)/.git" -a -x "`which git`"; then \
- REVISION="$$(cd "$(top_srcdir)"; LANG= LC_ALL=C git describe --always 2>/dev/null || echo)"; \
- fi; \
- if test -n "$$REVISION"; then \