summaryrefslogtreecommitdiffstats
path: root/main/lm_sensors
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-18 09:57:40 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-18 09:57:40 +0000
commit5e2f9aa50a1bac4353f5fd1a2d5c3251fbba60a3 (patch)
treebd050a8a758b44f1f504f0c22a4968ab8d46fe3f /main/lm_sensors
parentec56c6104f84980b4387dd935c47ca94cdd468c8 (diff)
downloadaports-5e2f9aa50a1bac4353f5fd1a2d5c3251fbba60a3.tar.bz2
aports-5e2f9aa50a1bac4353f5fd1a2d5c3251fbba60a3.tar.xz
main/lm_sensors: fix musl build
Diffstat (limited to 'main/lm_sensors')
-rw-r--r--main/lm_sensors/APKBUILD6
-rw-r--r--main/lm_sensors/musl-fix-includes.patch62
2 files changed, 67 insertions, 1 deletions
diff --git a/main/lm_sensors/APKBUILD b/main/lm_sensors/APKBUILD
index 878911e17..353f6956b 100644
--- a/main/lm_sensors/APKBUILD
+++ b/main/lm_sensors/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lm_sensors
pkgver=3.3.4
-pkgrel=0
+pkgrel=1
pkgdesc="Collection of user space tools for general SMBus access and hardware monitoring."
url="http://www.lm-sensors.org/"
arch="all"
@@ -12,6 +12,7 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-detect"
#install=sensors.install
source="http://dl.lm-sensors.org/lm-sensors/releases/$pkgname-$pkgver.tar.bz2
lm_sensors-3.1.0-sensors-detect-alpine.patch
+ musl-fix-includes.patch
fancontrol.initd
lm_sensors.initd
sensord.confd
@@ -68,18 +69,21 @@ detect() {
md5sums="60cfb98ab7a8915c3ac684af5459de2e lm_sensors-3.3.4.tar.bz2
b6e7de1a1768f7a6ea2e00c226331877 lm_sensors-3.1.0-sensors-detect-alpine.patch
+9411b5410420df8251c6e6c9c958fd89 musl-fix-includes.patch
58f4c9193a903711ace7fa0754693bd2 fancontrol.initd
2c7e97203da2c39bc9fbfc2a4849cfd4 lm_sensors.initd
82e075236a61334abb3adf46280380d3 sensord.confd
6f3a880988e7cdbcb20870e3c6d1e554 sensord.initd"
sha256sums="b4608610cb5de4b24e3fe1ae357712e8633a8a929bbb42df5eecc4ccee6ba76d lm_sensors-3.3.4.tar.bz2
f4b9e3cc57ae1e9f0a7145980e8019cbb630cc9b702c63f5b1cfb913735d5c7d lm_sensors-3.1.0-sensors-detect-alpine.patch
+e9bf572221a262bb53cefc86bea4d3d957a1e7962e6b3c0c2917fb3945bb7545 musl-fix-includes.patch
b231b76d5b32bb303a8e42727f48a4405cec71eedfe392e837acba5e46532783 fancontrol.initd
9b018f9f7a0975988387858823fe59a5cd8af6413d8c3170db0e24aac6021ec3 lm_sensors.initd
02230edf5efbb0a4de3840cd76f9ebf431c57a246fa7388e9dbeb0fe26fe7b8d sensord.confd
9f6d0e7bcdc1b4b3bc0835b40f246f7caf76e1b3bbfcf76a5d5b235eb8243d89 sensord.initd"
sha512sums="a375f747a1687da0fe743d731893156f7983e001725c2d7cd284cefd3e8922deb3dfe542d3c901e3da8fff321633d64180a637d780b5e1bb3f1e9a254c16b7e6 lm_sensors-3.3.4.tar.bz2
89e88759f7c69de62fe6c9056ea0cc2e9473898c11c7472c5ee4e264c5c00e1cac286b94cacab8bfe5a9b3f65829e244b8c39eb848d085f6e881dd97c5b84deb lm_sensors-3.1.0-sensors-detect-alpine.patch
+333751cb580c94f2d32ef5520d2f2acc0ef7e1cd4a6390ea75cae4c755fbdfcade1805c979ba3319905f1267bdc120a6746e6f70d89e0c72a8c2faefd34a9e79 musl-fix-includes.patch
e74d23ed78e066b903eb73e82ab9125bbaf81d86608fb0695314be20e06b777972547889fcfdf8271bcfd53b76a6a9db295f614ce7b73ea31b4d589009a5eb90 fancontrol.initd
16b3c7f742c70abcd310928be32fc63b0d344447776bc380be20f8708fbb72bc9b07ddec5ad867cfdc44247474aea3ff5d4f8b405cab896c07791a7a1834db7f lm_sensors.initd
a77d81ab7ded085ba19e4c637e93268f889ccb8ce9e008a210ae135cb6e2140be07e5d455cf7fcc1084fd57cfbfb3f2bb37207123aebe9566f78b5183806fd7d sensord.confd
diff --git a/main/lm_sensors/musl-fix-includes.patch b/main/lm_sensors/musl-fix-includes.patch
new file mode 100644
index 000000000..501f2dd76
--- /dev/null
+++ b/main/lm_sensors/musl-fix-includes.patch
@@ -0,0 +1,62 @@
+--- lm_sensors-3.3.4.orig/prog/dump/isadump.c
++++ lm_sensors-3.3.4/prog/dump/isadump.c
+@@ -36,13 +36,7 @@
+ #include "util.h"
+ #include "superio.h"
+
+-
+-/* To keep glibc2 happy */
+-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
+ #include <sys/io.h>
+-#else
+-#include <asm/io.h>
+-#endif
+
+ #ifdef __powerpc__
+ unsigned long isa_io_base = 0; /* XXX for now */
+--- lm_sensors-3.3.4.orig/prog/dump/isaset.c
++++ lm_sensors-3.3.4/prog/dump/isaset.c
+@@ -32,13 +32,7 @@
+ #include <string.h>
+ #include "util.h"
+
+-
+-/* To keep glibc2 happy */
+-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
+ #include <sys/io.h>
+-#else
+-#include <asm/io.h>
+-#endif
+
+ #ifdef __powerpc__
+ unsigned long isa_io_base = 0; /* XXX for now */
+--- lm_sensors-3.3.4.orig/prog/dump/superio.c
++++ lm_sensors-3.3.4/prog/dump/superio.c
+@@ -20,12 +20,7 @@
+ */
+
+ #include <stdlib.h>
+-
+-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
+ #include <sys/io.h>
+-#else
+-#include <asm/io.h>
+-#endif
+
+ #include "superio.h"
+
+--- lm_sensors-3.3.4.orig/prog/dump/util.c
++++ lm_sensors-3.3.4/prog/dump/util.c
+@@ -11,12 +11,7 @@
+ #include <stdio.h>
+ #include "util.h"
+
+-/* To keep glibc2 happy */
+-#if defined(__GLIBC__) && __GLIBC__ == 2 && __GLIBC_MINOR__ >= 0
+ #include <sys/io.h>
+-#else
+-#include <asm/io.h>
+-#endif
+
+ /* Return 1 if we should continue, 0 if we should abort */
+ int user_ack(int def)