summaryrefslogtreecommitdiffstats
path: root/main/ltb-project-ssp
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2013-06-11 09:53:02 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2013-06-11 09:53:02 +0000
commitb0c90ec75e729afa06e0f1f167f478db39a29d87 (patch)
tree2aac047b2299c99c46b8ba9040186159cadcd59f /main/ltb-project-ssp
parentf3dd5095137cc77d9c634e5bb670b6f024d499ad (diff)
downloadaports-b0c90ec75e729afa06e0f1f167f478db39a29d87.tar.bz2
aports-b0c90ec75e729afa06e0f1f167f478db39a29d87.tar.xz
testing/ltb-project-ssp: move to main
Diffstat (limited to 'main/ltb-project-ssp')
-rw-r--r--main/ltb-project-ssp/APKBUILD44
-rw-r--r--main/ltb-project-ssp/ltb-project-ssp-move-config-location.patch11
2 files changed, 55 insertions, 0 deletions
diff --git a/main/ltb-project-ssp/APKBUILD b/main/ltb-project-ssp/APKBUILD
new file mode 100644
index 000000000..afab26f06
--- /dev/null
+++ b/main/ltb-project-ssp/APKBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Leonardo Arena
+pkgname="ltb-project-ssp"
+_realname="ltb-project-self-service-password"
+pkgver="0.8"
+pkgrel=2
+pkgdesc="PHP application that allows users to change their password in an LDAP directory"
+url="http://ltb-project.org/wiki/documentation/self-service-password"
+arch="noarch"
+license="GPL"
+depends="php php-ldap php-mcrypt"
+depends_dev=
+makedepends="$depends_dev"
+install=
+subpackages=
+source="http://tools.ltb-project.org/attachments/download/497/$_realname-$pkgver.tar.gz
+ ltb-project-ssp-move-config-location.patch
+ "
+
+
+_builddir="$srcdir"/$_realname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ patch -p1 < ../ltb-project-ssp-move-config-location.patch || exit 1
+}
+
+build() {
+ return 0
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/etc/ltb-project/ssp
+ mkdir -p "$pkgdir"/usr/share/webapps/ltb-project/ssp
+ mv conf "$pkgdir"/etc/ltb-project/ssp
+ cp -r * "$pkgdir"/usr/share/webapps/ltb-project/ssp
+}
+
+md5sums="3132329678221221f9b8e94b8de3b360 ltb-project-self-service-password-0.8.tar.gz
+fd4c36fda7ed90cb11d242bc1139853b ltb-project-ssp-move-config-location.patch"
+sha256sums="e26d299ed6d2352056d545c3c5c826d296ff7a6152434db25196982dc14359d3 ltb-project-self-service-password-0.8.tar.gz
+f5cb978e5d45e09bf9923af8e337c7385448b350060a01f26eb9d061a1524340 ltb-project-ssp-move-config-location.patch"
+sha512sums="3586ba46b35badc37fbd562d884c9cd1f21527c31458231ed3af6848e919d9072251e11cbbdbf583f39901c6e37c85223be2682c0821d1553cba6911c339e6c7 ltb-project-self-service-password-0.8.tar.gz
+70151388b681a6af43d0861f3741ecf2573f1c9f4f79258bb7f66e54cd80ca57f895f371f5e1369c424f5a2059a406c90f8ad3ce3245357e5d2b51edf578826c ltb-project-ssp-move-config-location.patch"
diff --git a/main/ltb-project-ssp/ltb-project-ssp-move-config-location.patch b/main/ltb-project-ssp/ltb-project-ssp-move-config-location.patch
new file mode 100644
index 000000000..a7f0df712
--- /dev/null
+++ b/main/ltb-project-ssp/ltb-project-ssp-move-config-location.patch
@@ -0,0 +1,11 @@
+--- a/index.php
++++ b/index.php
+@@ -22,7 +22,7 @@
+ #==============================================================================
+ # Includes
+ #==============================================================================
+-require_once("conf/config.inc.php");
++require_once("/etc/ltb-project/ssp/conf/config.inc.php");
+ require_once("lib/functions.inc.php");
+ if ($use_recaptcha) {
+ require_once("lib/recaptchalib.php");